My Book Live DLNA subtitles (srt)

I own a Samsung HD-TV that supports DLNA and is able to stream a video along with an external subtitle file (an .srt file with the same name as the video).

I just bought a My Book Live and tried to stream a video I put into it to the TV. While the video streams fine, there are no subtitles even though the subtitle file is present along with the video file.

Is there any way to get the subtiltes as well? (some configuration I’m missing? maybe Twonky does not support subtitles and I can instal another media server that will …)

Any help would be greatly appreciated!!

Usually, movies streamed via Media Servers don’t usually support EXTERNAL SUBTITLES.   Most of the time you’d want to embed the subtitles inside the movie file.

It’s surprising that a TV would do that.    What model is your Samsumg?   I’d like to double check the manual.

Maybe that helps:

Its about the miniDLNA Server. I have this run on the WD MyBook as my Twonkey made me mad. But I do not use subtitles.

@ TonyPh12345 The TV model is: LE32B650.

@hurra I checked the link you gave but got somehow lost on how to instal miniDLNA to mybook.

Do I have to find a compatible binary, send it via ftp and install it?

Is there something already available through apt-get?

Do I download the sources and try to compile directly on mybook (that would also require all deps plus a compiler in mybook) or cross-compile and send the binaries?

Could you provide some easy to use steps?

Thanks a million!

The bad news is: you have to compile the source, unfortunately.

The good news is the box uses a debian linux and so it’s not that painfull.

If I remember right, the box is able from scratch to compile, but to be sure read about the necessary libaries.

Then you can compile by downloading the source to “/” then untar to a new folder and use “make” I guess to produce the binary. All necessary libaries etc. are copied to the right place by the compiler.

As far as I consider, you can use then the dlna - maybe make sure its startet at boot.

Basicaly I suggest to read some articles about compiling - good source @ubuntu as this is based on debian as well.

I think I used the following:

good luck

Thanks a lot for the information.

I already installed the necessary toolchain (gcc, make, etc) and will continue with the miniDLNA required libraries. The link you gave gives pretty straightforward instructions so i guess i won’t have a problem.

Hopefully after the compilation and deployment I’ll be able to have subtitle support!

I’ll post my results later tonight.

Thanks again for all the help!

EDIT: Indeed, the instructions were very easy to use and easily compiled miniDLNA. I now have subtitle (at least a checked with an .srt) working and it works like a charm!!

Thanks a million!!

As mentioned in the last post, miniDLNA now works and I get subtitle support.

The problem is that this is the case only when using media located in a folder of the boot disk and not in /shares.

It seams that the problem is related to the /shares using xfs filesystem while the folder I successfully stream from used ext3.

Is this a known miniDLNA limitation?

I also tried other media servers like MediaTomb which worked ok with the xfs filesystem and streamed the data but had no subtitles and uShare which again accessed the xfs filesystem but couldn’t get the TV to recognize the media.

Would it be possible to just format the xfs filesystem to ext3 and use miniDLNA as it is (and how do I do that?)?

Otherwise are there any suggestion on another media server / another configuration of the already used ones?

Again any feedback would be greatly appreciated!

Actually I was using two configurations and as it turned out i had different problems for each case…

On My Book Live I apparently had some error in the config file, as I tried it again and it worked just fine (both main disk and user disk data are visible).

The problem was on My Book World Edition where I installed MiniDLNA through optware (cvs20090413-2) but I could not get it working for neither folder. I run minidlna in debug mode and saw that at the beginning it adds the watched directories (/opt and subfolders) but there is no trace of my directories being added to the watch list.

But I guess that this question is for another thread…