My Book Live discovered, but can't map to it in Win XP


#1

I’ve been trying to do this “easy” installation for several hours now.  Initially, I couldn’t get my Windows XP PC to discover it at all.  However, I could get to it directly via the IP address.  I was able to determine it was a firewall issue.  Once I enabled UPnP and updated the firewall to trust the IP address, the discovery tool worked just fine.  Via the discovery tool, I could open the Public folder and access the settings and all of those good things.  However, the step to Map the drive didn’t actually do anything and the shortcut created doesn’t work.  Furhermore, typing \MyBookLive\Public in explorer to get to the drive doesn’t work.  The only way I can get to the drive is through the discovery tool or by typing in the IP address in explorer. 

I have yet to figure out how to get the drive mapped.  Also, explorer only kind of shows the drive.  What I mean by this is that it doesn’t show up at all under “My Computer”.   At the root of “My Network Places”, it shows MyBookLive, but doesn’t allow you to open it up.  Also, it doesn’t show up in the workgroup unless I type in the IP address to get to it.  Last, but not least, from a command line, \MyLiveBook does not show up with the net view command.

What’s the problem and how do I fix it?  It’s as if parts of Win XP detect it, but something is preventing full access.  It’s probably more firewall or network settings, but I’m no IT expert and am at a loss for what to try next.  Very frustrated at this point.


#2

You need to make sure your FIrewall isn’t blocking ports 137 thru 139.

Also, you need to make sure the MBL is in the same WORKGROUP as your PC.


#3

they are in the same workgroup.

I already tried completely turning off my firewall.  There was no change in behavior.

It kind of shows up in the workgroup in exporer if I type in the IP address, but not really and not permanently.  I can map to the IP address, but not to “mybooklive”. As soon as the (dynamic) IP address changes, I’m screwed. Besides, I’d like the thing to work properly & not require the IP address.


#4

… then whatever is providing NetBios Name Service in your network isn’t working right.

The below detail talks about the WDTV Live products, but the same information applies here…

http://community.wdc.com/t5/Networking/Troubleshooting-Windows-File-Sharing/m-p/92642#U92642


#5

I restarted my router last night, and it assigned IPs in descendig order to what was turned on first.  So the vista laptop was on, that got .199, my xp PC got 198, the Wii was powered on later, that got 197, and finally I plugged the MBL back in and it got 196.

I then went into my wireless router settings and increased the time each PC has a DHCP IP reserved.  I Then added the currently-assigned IP of the MBL to the “reserved” list, which, if I understand correctly, will assign that same .196 IP to the MBL every time.

Lastly, and I say this every time, try changing the DNS of your PC to, say, google’s DNS service of 8.8.8.8.  Give it 24 hours.  that resolved all my http://mybooklive and status icon issues.


#6

Hi All,

I am also having identical problem with MyBook Live 2TB recently purchased, where I can ping the drive but cannot map the drive.

But I have just solve this problem by a very simple step.

I am running WindowXP Pro. My problem is due to the missing “Client for Microsoft Networks” in the Local Area Connection Properties.  After I added this missing entry, I am immediately able to access the public folder in MyBook Live.

Hope this solution will help.

Cheers !!!