My book live can't access drive

My book live 2tb started to click the other day

I ve tried a number of fixes i found on here and am part way through one using a systemrescue cd and gparted. this is what i get after the first step

[root@sysresccd ~]# mkdir /mnt/usb
mkdir: cannot create directory ‘/mnt/usb’: File exists

I then tried to see if i could see the drives and this followed:

[root@sysresccd ~]# lsblk
loop0 7:0 0 638.4M 1 loop /run/archiso/sfs/airootfs
sda 8:0 0 1.8T 0 disk
├─sda1 8:1 0 1.9G 0 part
├─sda2 8:2 0 1.9G 0 part
├─sda3 8:3 0 489M 0 part
└─sda4 8:4 0 1.8T 0 part
sdb 8:16 1 7.5G 0 disk
└─sdb1 8:17 1 7.5G 0 part
sr0 11:0 1 699M 0 rom /run/archiso/bootmnt
[root@sysresccd ~]# fdisk -l
The backup GPT table is not on the end of the device. This problem will be corrected by write.
Disk /dev/sda: 1.84 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: WDC WD20EARX-00P
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 14E3AE25-6A4D-47BE-B348-8F0F6BA359AD

Device Start End Sectors Size Type
/dev/sda1 1032192 5031935 3999744 1.9G Linux RAID
/dev/sda2 5031936 9031679 3999744 1.9G Linux RAID
/dev/sda3 30720 1032191 1001472 489M Microsoft basic data
/dev/sda4 9031680 3907028991 3897997312 1.8T Microsoft basic data

Partition table entries are not in disk order.

Disk /dev/sdb: 7.51 GiB, 8053091328 bytes, 15728694 sectors
Disk model: ProductCode
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0019d088

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 64 15728693 15728630 7.5G b W95 FAT32

Disk /dev/loop0: 638.41 MiB, 669409280 bytes, 1307440 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Any advice greatly appreciated

Its a bit late, but I have had a lot of issues with my WD Live. I was able to get access to mine by going to the Windows File Explorer. Right click on Network. Select “Connect to Network Station”. I selected the drive adress “\mybook” (Yours may have a different adress) and selected a drive name such as z: and used my login credentials after checking both boxes.

It may not work for you, but it did for me. My WD drive denies connection at random frequencies, and it seems like it does it if a certain number of units has connected to it.

Will try to avoid WD in the future since this issue has been unsolved for since I bought it about a decade ago. Which is the best thing about the WD Live. It lives for a long time. Mine has been running since I bought it, with no other issues than one of the most important features for a network drive. Being able to connect to it.