My Book Live 2TB No longer appearing on the network


I had my My Book Live working on my network with Twonky 7. All was great until I updated the firmware and it reset the Twonky version to 5. I tried to fix this but without success and now have a device that is connected to my netgear router but does not show up as a device with an ip. I have tried pushing the reset button to reset to factory settings but it still doesn’t respond. when i try to see it on the network there is nothing.

the ethernet connection has green flashing lights from the router and i have a green light on the front of the unit.

Can someone help me to 

  • get the unit showing up on the network while not losing the data
  • reset the firmware & twonky to something that works.
  • how to update the twonky version from 5 back to 7 using a mac book pro

I have read a lot of the posts and not being a linux user find it difficult to know what I am doing but I can follow instructions

Many thanks for anyone who can help

One basic rule of hacking:

Never run official code afterwards.

Your drive’s warranty is already void so you can try to take it apart and connect the drive to a Linux computer normally via SATA.