My book is not responding. Led turned on. Not reading

I have a 3tb drive, is a normal version, don’t really know the name, but is only the hd, not live, it worked properly before, but today, it was plugged in my pc, and the led was turned on, even when my pc was turned off, when I turned it on, the hd was not recognized, it first said that something was being installed, but then, nothing happened. I have already, plug and unplugged it, turned it off with a button that has in the back side, unplugged the charger, but when I connect it again, the led turns on, and the hard drive starts “reading”, but only for some seconds, the PC doesn’t recognize it, and I have almost 2.5 tb of information. Has it happened to someone? Could someone help me?


PS: The HD is Mybook essential

I have seen many users with the same problem, but no one has an answer. :confused:

need more info… right click 'my computer,>click ‘manage’>then click ‘disk manegement’

check there if your drive is being seen or not. do not click anything else

check below the one where the is a graph.

If I unplug the HD from the AC cable and the USB, wait some minutes and then plug again, the HD starts rolling, but it does not appear in the explorer, i tried with chkdsk and it says (G:) Is not found. Sometimes after plugging and unplugging it, there appears a message that says the HD needs to be formated in order to be read, so, i haven’t done it because i don’t want to lose all my files, and even because the HD stops working (rolling inside) after some seconds.

OH, i have already done the steps you said, but only appears the partitions from the HD inside the computer, i used to change the letter of my hd there, but now it is not shown anymore.

Thanks for answering. :slight_smile:
Do you know if it could be fixed?