My Book is locked, and I no longer have permission to access it!


#1

I have a My Book Studio Edition II 2TB external hard drive that I had been using with Time Machine on my iMac.  Currently, my iMac is getting serviced, so I’ve hooked up my external drive to my MacBook Pro; however, my computer keeps telling me that I don’t have permission to access the My Book on my Mac Book.  I’ve tried changing my Sharing settings on the My Book and I’ve tried repairing it in Disk Utilities yet nothing has worked.

Does anyone have any suggestions on how this could be fixed? Or will I probably have to restore the My Book?

Thanks!


#2

Time Machine on your iMac, put controls on the My Book Studio.  If you don’t care about the data on the Studio drive from your iMac you could probably force Time Machine on your Mac Book to take control.  But I would look into this with Apple to make sure you don’t mess up your backup on the Mac Book Pro.


#3

Fortunately I didn’t lose any of my files on my iMac so I no longer care about the files on the My Book, I just want to be able to use it again.  Is there a way to factory restore the My Book?

Thanks!


#4

You could try just reformatting the drive, and see if your Mac Book will take it over.

[edit]

I should preface what I said with, I don’t know a lot about Time Machine or Macs.