My Book Home not detected by iMac


I own the 1TB My Book Home external hard drive (HD) and have been using it for over 2 years now. My system is an iMac running Snow Leopard, to which the HD is connected using a FireWire400 cable. HD has been running smoothly since first day of usage. I have three partitions in it: 1 FAT32 and 2 Mac formatted.

The HD was working just fine when I booted my machine yesterday morning. But it suddenly got disconnected and until now it cannot be detected anymore. I tried disconnecting and reconnecting the cable from both ends. It didn’t work. Then I tried using a USB2 cable. Still to no avail. When I start my machine now, the HD boots along just fine and I can hear the spinning sound from within. The light at the front of the HD is usually moving but it no longer does now. After a few seconds of start up, it makes a kind of “slicing” sound (as if it is attempting to look for something, but couldn’t find) and then stops after a couple of attempts. It’s never been dropped or knocked hard. It’s always been functional without any problem so far. When it got disconnected, the error message just said that it is disconnected without any reason.

I hope I can still recover my data. I am running my Time Machine backup regularly there.

Thanks in advance!

Just tried the help from this thread:*hSUvfk&p_faqid=505&p_created=1030579863

It’s still not working.

The HD does not show up in Disk Utility too. Previously it did before the problem occurred.

Amazingly I am experiencing the same issue - 2+ year old MyBook Studio II 1TB set up as RAID - no longer recognized by iMac Core Duo running 10.6.5.   Worked fine until today - Tried turning on/off - no joy - the light on front panel is steady on 

Anyone have any ideas?

I might have good news for all of you! Had the exact same problems you guys were having. Not sure why I tried this but I did. I switched the power cord that came with my hard drive with another standard DC plug and it worked like magic, never heard of this happening but Im taking it my power cord had a short or something. Thank god I tried this cause I was about 24 hours away from jumping off a bridge. Buying another hard drive in the morning to make sure everything is 100% backed up this time. 

I am having the same problem.

Well, I seem to be experiencing multiple WD drive failure as one drive after another in the last two days has decided that while it might be seen by my Macbook Pro, it will not be mounted.  As I tried the different cables, different ports, different power cables, plugging in and out in prescribed order, I’m at a really confused point.  For the moment, my computer still recognizes my passport.

Is anyone else solving these problems?  Has there been a recent upgrade for both WD and MAC that’s conflicting?