My Book Home Edition 1 TB (FAT32 formatted) has suddenly a big problem writing or reading


#1

Well, I have a MacBook 2 core and a HP Pavilion and suddenly I have a big problem writing or even reading my external harddrive from my MacBook. I have the My Book 1TB drive for over a year now without encountering any problems until now.
The strangest thing is that it is fully accessible from a windows computer but when i plug it to my macbook after a few
moments I can’t access it properly. No file can be copied anymore although I see the directories and can access them but now the files can’t be launched whatsoever. Also I have to force eject the drive every time now.
This is what I got when running the “Data Lifeguard Diagnostic for Windows” over my drive:

Test Option: QUICK TEST
Model Number: WDC WD10EAVS-00D7B1
Unit Serial Number: WD-WCAU45420086

Firmware Number: 01.01A01
Capacity: 1000.20 GB
SMART Status: FAIL
Test Result: FAIL
Test Error Code: 06-Quick Test on drive 2 did not complete! Status code = 04 (Unknown failed test element), Failure Checkpoint = 96 (Unknown Test) SMART self-test did not complete on drive 2!
Test Time: 19:14:52, March 27, 2010

Test Option: EXTENDED TEST
Model Number: WDC WD10EAVS-00D7B1
Unit Serial Number: WD-WCAU45420086
Firmware Number: 01.01A01
Capacity: 1000.20 GB
SMART Status: FAIL
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 01:10:22, March 28, 2010

It aborted at 200 million of 1,9 billion sectors.

So, now I know I have bad sectors and I hoped that scandisk would be able to repair or at least reassign the bad sectors.
So I ran the program with automated error repair and reassignment of bad sectors. The process took several hours and at the end there was not prompt of any problems.

But problem remained

Also the Mac diskutility program wasn’t able to do much. The checking function if it worked showed this:

2010-03-27 14:08:03 +0100: Volume „RUSTYT“ überprüfen
Überprüfung wird gestartet: 2010-03-27 14:08:03 +0100
2010-03-27 14:08:46 +0100: ** /dev/disk1s1
2010-03-27 14:08:46 +0100: ** Phase 1 - Preparing FAT
2010-03-27 14:08:46 +0100: ** Phase 2 - Checking Directories
2010-03-27 14:08:46 +0100: ** Phase 3 - Checking for Orphan Clusters
2010-03-27 14:08:46 +0100: 34706 files, 315739840 KiB free (9866870 clusters), 52736 KiB bad (1648 clusters)
Überprüft: 2010-03-27 14:08:50 +0100

And the repair function all the time showed this:

2010-03-27 14:09:36 +0100: Volume „RUSTYT“ überprüfen
Überprüfung wird gestartet: 2010-03-27 14:09:36 +0100
2010-03-27 14:09:51 +0100: Das Medium „RUSTYT“ konnte nicht deaktiviert werden.
2010-03-27 14:09:51 +0100:
2010-03-27 14:09:51 +0100:

I tried several other programs like Powerquests Partionmagic for Windows it showed me several errors for the drive but those were corrected by scandisk.
Then I tried DiskTools Pro for OSX with the same results as the diskutility program. It wasn’t able to scan or repair the volume/files.

So now I’m really stuck and desperate. Is there any hope that the problem can be solved with software.
I also downloaded the last firmware update but I’m hesitant to install it regarding all my problems.


#2

Hello,

Suggestions:

a. Plug the WD external drive to your HP windows machine.

b. Back up all files to the internal drive.

c. Format the WD external drive with FAT32 file system. Do the FULL FORMAT.

    it may take longer but, it will check everything unlike the quick formatting.

Re-format the drive is the only way out once the drive has bad sectors.

Try to scandisk or repair while all of your data is still there is not safe.

If after backing up all of your data, format the drive or it fail the full format and still facing bad sectors.

You might want to contact WD tech support to get your drive replace if under warranty.


#3

I probably will do exactly that. I only have to find someone with 600 GB of spare space to transfer my files.

I’m going to format the the HD with a NTSF filesystem and will use Paragon NTSF for Mac in the future.

But I will definitely make the long formatting with NTSF