My Book Home 1TB doesn't work light on and off


#1

Today just an hour ago I need a file on my WD My Book 1TB external drive.I plugged it to my PC but it didn’t  detected by PC .later when i look at the disk it shows just the in front  the light just on and off very fast .I tried on many USN ports on my PC  i tried my friends external drive it’s samsung it works .but mine isn’t works it just show me the light  as i told the light on and off very fast.

I can’t understand why it doesn’t work .I didn’t use it for week it was in it’s box on the desk.Never touched a week and now it doesn’t work.

Any body in here get any problems like mine?I send email to WD support I’m waiting for their answer  .


#2

Anyone know how to solve this?


#3

The flashing light on the front is not a good thing.  Have you tried contacting WD’s Technical Support about this? You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#4

i have the same problem, mine 1.5TB. what’s wrong?pcb?can i got replacement?not for the drive, i have a lot of data on that disk and no time to move it.