My Book Home 1TB connected by eSata disappears after going to sleep


#1

 My external drive goes to sleep every 10mins or so, then when I try to access it it’ll wake up for a second and then disappear completely. The entry is gone from Device Manager, and rescanning for hardware doesn’t find it.

I have to replug the power cord to get it to show up again. It’s quite annoying.

USB works fine, but I bought this drive for the eSata connection.

Plenty of people online have the same problem, but there isn’t a real fix for it.

I’m not going to try the “touch” software method of keeping it awake. I don’t mind that it goes to sleep, just that it won’t come back.

It used to work fine until I changed computers. Same OS (Windows 7 Ultimate) just different hardware. I’m trying to run this on a Zotac H55-ITX. It has one dedicated eSata port.

I’ve tried getting the latest JMicron 36x eSata drivers (v1.17.55), updating my BIOS, changing the drive settings to IDE instead of AHCI and setting the drive to never sleep. Nothing works.

This is getting extremely frustrating.


#2

I have the WD My Book Home Edition 1.5TB  (Model WD15000H1CS-00)  with firmware version 1.034

I use the eSATA port to get maximum transfert speed.

Unfortunately, I have the same problem when the hard drive wakes up from sleep: the hard drive disappears.

I run on Windows 7 x64 with an eSATA JMicron JMB363 Controller on the ASUS P5K-E motherboard with the most recents BIOS firmware and JMicron driver.

I think that the JMicron controler could be the problem. But I think that Western Digital could give us the choice to install a firmware to disable the automatic sleep mode inside the drive.


#3

Finally a reply! I knew I wasn’t the only one.

Regarding the JMicron controller, I wish I knew what the brand was on my old motherboard (XFX 780i). If it’s not JMicron I’d be convinced that it’s the SATA controller.

I think the automatic sleep function is the biggest peeve that people have with the WD externals, and I agree we should at least have the choice to turn it off, but for me that would be a temporary solution. I like the sleep function, just not when it acts like this.

EDIT: Looking at the changelog for the latest JMicron 363 drivers, it and the previous release were specifically to fix problems with external HDDs. I’m pretty sure it’s the sata controller now too.

Out of curiosity, did you use the drivers from here:  ftp://driver.jmicron.com.tw/jmb36x/XP_Vista_Win7/, and if so, did you use the 1.17.55 file ending with “eSata” or “WHQL”. I picked the eSata one for obvious reasons.


#4

If Western DIgital is reading this, this problem makes this drive virtually USELESS for what I am using it for in a commercial environment. And to think I was recommending these to other people, no longer can I do that in good conscience.

We use them for backup and primary, mobile data storage. So for instance, I use mine to back up a bunch of data from my workstation, but also as the PRIMARY storage of my Virtual Machines for VMWare for software development and testing.  When programs are open against the drive, it *CANNOT* go away, or data corruption and loss could ensue.  I have had to begin backing my MyBook up to my workstation frequently to be safe!  (PS: The lack of SMART data through the e-SATA connector is also a significant limitation for us as well, we’ve had a couple of hard drive failures and would like a heads-up that trouble is brewing and move the data to a replacement drive *before* data loss occurs.)

I have the same problem and I’m running a Dell with Intel chipset and drivers, so it’s a hardware issue within the board on the MyBook.  The box goes to sleep and won’t wake up the board or perhaps the "green drive’ that is inside.  What I noted was that the led’s were completely dark, Windows XP was complaining about delayed write fail and when I dropped to a command prompt and did a DIR, the led’s came on, but the drive did NOT spin up.  I got cached data and that was it.  As said above, I had to power cycle the MyBook to get the drive to spin up, then everything was fine.

This is incredibly annoying, as I can’t leave a VMWare Virtual Machine  open  over night, as if they are idle, then everything crashes down because the drive goes to sleep.  I guess until there is a fix (doubtful), I’ll have to resort to a scheduled “poke” like touch or repeatedly over-writing a dummy file on the drive.  I’m not sure how long it takes to go from idle to “active sleep” to “deep sleep” however.

Perhaps swapping the “green drive” for a non “green drive” would alleviate the problem.


#5

I have the 1.5TB Home Edition.  Very annoying.  If I am not constantly accessing the drive, it will enter sleep mode, lose it’s drive letter in Windows, and will not come back until I pull the power plug from the drive.  Need a way to disable the sleep mode.  What is up with these drives Western Digital?


#6

Thing is, it worked fine before I got my new system. Sleep mode was annoying, since it took several second to access the drive again, but it never dropped out completely like this.

Disabling sleep mode would just be treating the symptoms (although it WOULD fix the problem).

It’s got to be the SATA controller drivers imo.


#7

It is interesting that you never had the problem before changing machines JimmyS. I would also initially think that this means there could be a difference in the drivers, but I don’t necessarily agree that it means the problem *is* the drivers.  The one driver may have regularly “poked” at the drive for information, keeping the MyBook controller and drive awake, and the newer, possibly “Greener” driver may not do that. The driver may have masked the problem for you.

The main clue that points to where the problem lies is that if it only refuses to wake on SATA and not USB, then it may be a difference in the implementation of the two interfaces on the little controller inside the MyBook more-so than the drivers for the computer’s SATA interface.  Another piece of “evidence” of different engineering on the eSata interface is that they don’t pass through SMART data, yet it’s available for USB.

I’m going on anecdotal evidence here, as I haven’t tried switching back to USB for an extended period of time to see if it does it or not on USB.

PS: Mine sat all weekend un-touched and had gone to sleep, it just woke up fine when I went to My Computer and clicked on the MyBook drive letter.  I heard the drive click and spin up and now it’s doing a chkdsk fine, so it’s fully awake.  I didn’t leave anything running that should have touched the drive regularly over the weekend.


#8

I have the same problem…windows 7 64 bit, esata connection - drive goes to sleep even when such applications as photoshop are running with a file open on the drive.

One piece of information I can contribute, my laptop which is an HP has a built in esata port and the drive either doesn’t go to sleep using it or I have never had it connected long enough for it to occur yet.  The times mine goes to sleep can vary between a few minutes and several hours (even without activity).  I have the custom power management profile set for drive to never sleep.

I tried to update the bios today with the one from the download page but it gives an error about “error while loading generic library”  Searching for this earlier, the only response was “you are using a 64 bit operating system and you need to use a 32 bit operating system to upgrade the firmware”…and well, my 2 desktops and laptop all run either 64 bit windows vista, windows 7, or gentoo linux


#9

i have a 1 gig my book drive and about the same problem.

after being idle for 10 min it’ll go to sleep and when i try to access it will take at least 2 to 5 min before i can acces it.

it’s connected as this thread implies with esata.

it’s very anoying and sometimes causes to freeze my whole pc for a while, and i’m sure it’s not the pc’s hardware causing the issue but the drive going to sleep. as all internals work perfectly.

what i do now is after it being idle i turn it off and on again which is twice as fast but as annoying as waiting 2 - 5 minutes. :cry:

i would like to see an expert telling me what they think, as the only replies so far are complaints and thought (which offcourse is also good).

if anyone can tell me/advise i’d be very gratefull.

cheers


#10

I can confirm that I have the same problem of drive going to sleep and disappearing from MyComputer after 10 minutes or so (with eSata). However, this problem had become of secondary importance after I discovered a problem I posted here http://community.wdc.com/t5/My-Book-for-PC/file-system-errors-when-using-eSATA-with-MyBook-Home/m-p/12307#M778.

Am I really the only “lucky” one? I stopped using Esata with the drive because of its inability to pass Check disk.


#11

To TechieInClagary: The thing is on my old machine the drive definitely went to sleep, and wasn’t being ‘poked’ . When I tried to access it, it’d take about 10 or so seconds to wake up again but it worked fine (sometimes freezing my computer for a second). This is all while connected by eSATA.

I really don’t know what to think now, but I’m using USB out of desperation. Perhaps I should try using an older JMicron driver?


#12

@JimmyS

I discovered that mine wakes up most of the time now, even after a weekend, but from time-to-time it doesn’t. I’m still using eSATA on the above configuration. I did apply the latest firmware to the controller card and it is a newer drive - 1.5 TB, my old 1.0 TB drive packed in the ghost physically… platter damage it seemed. I have since moved the drive to the desktop instead of on top of the computer itself.


#13

This problem is beyond annoying!!

I have a Gigabyte GA-X58A-UD5 motherboard (JMicron JMB362 chip) and the MyBook Home 1Tb drive.  I’m using the 1.17.55 JMicron driver.

The drive drops from the system 5 minutes (exactly!) after plugging it in.  It makes no difference if I’m accessing it or writing to it.  The only way to get it back is to power cycle it with the plugin cord.

Totally useless for a backup system and I must have major filesystem corruption because of all the drops.

Curtis


#14

@trinitonesounds

That sounds quite unusual and is definitely not my experience. I use mine every day at work to run things off of, not just as a backup drive. During the day, whether I’m accessing it or not, it seems to work fine. For instance, just now, there were no lights as I hadn’t accessed it for a long time, but it woke up as soon as I began accessing the drive to open the properties page and run a check disk.

Have you tried putting the latest firmware on the “controller board” of the MyBook? You hadn’t said one way or another in your post.

Edit: I’m beginning to wonder if some of this may be related to the power settings. Are some of these systems set up to power down drives if they are idle, and others are not?  I’m not even sure what my setting is, but it’s a thought.


#15

I have the exact same problem - found this forum when I was searching for solution.

My two 1.5GB WD drives just disappear after a while - and there is no icon to try and bring them back.

I literally have 13 different external hard drives - and the two WD MyBooks are the only ones that exhibit this problem.

I have an Intel XBX2 motherboard, which uses the Marvell Raid for their eSata. WD “dies” until reboot with it.

I also have a Silicon Image RAID card, which the 2 WD drives are conected to. Same problem.

Conclusion: it’s not the computer controller, it’s the WD drives themselves (or more specifically the WD interface)

It’s an insane and frustrating problem for me. I cannot rely on them and have to unplug/plug them in person every time. So much for the benefits of having a network and working remotely…


#16

Update: I have the latest firmware and still (randomly) the drive shuts down. I also work remotely and my VM’s are on that drive, so suddenly, I’m pretty much unable to do my work.  I don’t have any power-down settings or anything. I’ve followed some “advice” and have a windows scheduler process that over-writes a file on the filesystem with the date and time every 10 minutes in an attempt to keep it awake.  I definitely have write caching turned off at the OS!

If I recall, it went to sleep once even with *that* running!


#17

Similar problem here! In my system, this drive causes windows 7 to crash when the drive powers down. If I had checked this forum sooner, I would have returned this drive to fry’s. How can WD know about this problem (since it is described here) and not fix it? I will likely remove the drives (4 TB) and trash this enclosure. Or, maybe someone would like to use it via USB? Any takers? 4 TB WD 40000h2Q-00


#18

Something I didn’t see above… First things first, make sure you modify your Operating Systems power settings.  Especially disabling anything like hibernation or suspend to disk.

Does the Same but Worse with USB

I went to Fry’s electronics and purchased a card specifically for faster access, no matter what I try, from a full zeroed out drive on a MAC, on XP, and Linux, this is the SLOWEST and WORST hard drive I’ve ever seen.  And I’ve been around since 4MB was considered to be humongous.  This is the 10th post about this sucky drive I’ve seen now… and NO WD response.  If I don’t see a WD response to this I’m done with WD forever, and I’ve been a customer for 20 years.


#19

AskApache wrote:

Something I didn’t see above… First things first, make sure you modify your Operating Systems power settings.  Especially disabling anything like hibernation or suspend to disk.

 

Does the Same but Worse with USB

I went to Fry’s electronics and purchased a card specifically for faster access, no matter what I try, from a full zeroed out drive on a MAC, on XP, and Linux, this is the SLOWEST and WORST hard drive I’ve ever seen.  And I’ve been around since 4MB was considered to be humongous.  This is the 10th post about this sucky drive I’ve seen now… and NO WD response.  If I don’t see a WD response to this I’m done with WD forever, and I’ve been a customer for 20 years.

Sorry, guys, but it’s doubtful that you will see a response without me escalating this.  This forum is not a support forum.  I will escalate this thread and see if I can get you some help.


#20

No WD drive with eSATA will sleep on its own and disconnect itself from the computer by design.  If the drive disappears from a computer then there is a hardware connectivity issue.  All WD MyBook drives use the power signal from the data cable to decide whether to stay on to turn off.  Therefore, the drive will turn off or appear to “sleep” if the data connection disappears.

WD has released firmware updates for our eSATA drives so I recommend checking our downloads page first to ensure your drive has the most up to date software.  If the drive’s firmware is up to date then any of the following scenarios will cause the same symptom:  

  1. The drive is oriented horizontally instead of vertically.  WD designed the MyBook family of drives to passively vent heat through the top and they may overheat when placed horizontally.  See WD KB # 1186 for reference.

  2. The eSATA cable too long for the eSATA controller.  Many eSATA controllers only support 1 meter (3 feet) cables and will not work consistently when using a longer cable.

  3. The eSATA port connected to the drive is not one from a dedicated eSATA controller but instead a bracket that converts an internal SATA header into an eSATA port.  The SATA ports on most motherboards and controller cards are designed only to push data through 18 inches of cable.  Most eSATA brackets use a 12 or 18-inch cable.  If you factor that length together with the eSATA cable itself, the eSATA device will not be seen consistently or at all.

  4. WD has a list of known-good eSATA controllers on KB # 1524.  Other eSATA controllers may certainly work but are not known to function.  When using an eSATA controller not on our compatibility list, unfortunately your results will be unpredictable.

Please note that the eSATA cable itself must have a firm connection with the drive and controller.  If the connection is loose then the drive will not operate consistently or even at all.