My Book got unplugged, now can't access anything on it


#1

I have a 1tb My Book external HD. It always used to come up under “My Computer” as the E: drive. I just went to go open it up and it was no longer there. I looked at the HD itself and it looks like my girlfriend unplugged the power adapter from it. I plugged it back in, the lights came on, and in the bottom right corner of my monitor said it was looking for the drivers. Few minutes later that went away so I tried My Computer again and still wasn’t there. This is everything I’ve tried to do since:

 Hit refresh

Restarted my computer

unplugged it from the USB port and plugged it back in

tried a different usb port

Uninstalled, then reinstalled the driver

Tried to find it in Disk Management.

In Disk Management under Disk 5 it says “Unknown Not Initialized”  but when i right click and try to it says “Incorrect Function”.  In Device Manager it shows up under the USB port as a Mass Storage Device, and it says its working properly.

Oh Im using Vista on a PC.


#2

I have that same HD, as far as I know there are no “drivers” for it that came with it, it uses the windows pre-installed drivers. That being said you may want to try a differend USB cord. I had the same thing happen to me and if you power down your HD and unplug the cords let it sit for like 5 minutes, restart your computer, then plug it  back in to an outlet then to a usb port. This should jump start the add hardware wizard. If it successfully adds the hardware then wait a couple seconds to see if WD Smartware brings up the login so you can access the HD if not then restart once more (you don’t have to power your HD down as windows will peerform its safely romval of hardware where you go through Start menu restart). It should come up after that.


#3

Just tried all that, didnt work :frowning: