My Book from 2011-2012 Failed?

Hey guys and gals

My 2TB external HD just failed I think? It won’t mount unless I run disk utility and isn’t recognized on any of the other macs in the house that I have plugged it into. I changed out the USB cord and nothing. Once disk utility finally recognizes it, it tells me that I cannot copy anything onto the HD but I can copy things from it. I ran the WD Drive Utilities tool and while the SMART status said it was ok, both the other tests failed.
What do you guys think?

This is the second time this has happened. The first time my drive was under warranty and they replaced it with this. This time. It’s been 5 years.

Also I’ve done all the updating to my OS and unplugging of cables and such. I think the HD is corrupted or damaged or something. It sits on my desk in it’s normal position and doesn’t move.

If the all the disk tests show that the drive is okay, and the drive shows up in Disk Utilities, but won’t mount to the desktop, then it is possible, even probable, that the file system is corrupted. You can try searching data recovery software that can restore the partition, but you won’t be able to recover any files that are corrupted.

Only the SMARt disk check says its ok, both the other tests FAILED. Will the data recovery software make this external useable again?