My Book for Mac set up issue with time machine; and password won't work

I posted this elsewhere, and I thought it might be more appropriate here.Just arrived here guys. I have downloaded updates onto a sytem which was a dodgy set up to start. I clicked yes to using time machine when I set up, then had second thoughts and turned off TM in utilities.

My Book for Mac did back up successfully if slowly when combined with TM. I had 95 gb of data. Everything worked, although I wasn’t too sure about the limited options on the home page. But now, the password doesn’t work so I can’t uninstall My Book, I can’t install the downloaded updates; I can’t do anything.

I tried turning TM back on, but of course that didn’t help.

 Any ideas would be appreciated. Thanks.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


I agree, I would contact wd for tech support.  but just know that with your os acting up, who knows what’s causing this.