My Book for Mac can't be detected!

I have been using my new My Book 3TB external drive model WDBYCC0030HBK-NESN to back up my photos and videos. It was working fine until I left it disconnected from my iMac for a week, reconnected it and the computer wouldn’t detect it! I tried all of the suggestions in the WD Community forum without any luck and tried the procedures recommended by WD Support via email and to no avail, they just don’t detect the product.
iMac disk utility doesn’t detect the external hard drive either.
I checked the power cable it is providing between 12.18 and 12.20 VDC. The USB cable must be working because when I plug it in to MY Book the light at the front of My Book goes on and flashes slowly, whereas with only the power cable plugged into the My Book the light does not go on. My iMac (27 inch) is using El Capitan ver. 10.11.2, and MyBook worked fine with it for at least two weeks before this problem arose! Please help, I need to access the photos and videos!


As a recommendation, test the unit on a different computer and just in case try using a different USB cable.

Also make sure that the power adapter is connected to the wall outlet.