My Book fast blinking light, files not accessible

Here’s a summary. Any help identifying the problem appreciated.
WD desktop WDBAAF0015HBK-01 USB 2.0…With WD Smartware password encryption.

Using known to be good cables (I have another WD).
USB 2.0 in, power cable in.
I can hear disk spin up. No abnormal sounds.
WD Smartware password prompt comes up, password entered.
Loads very slowly, File Explorer window opens after 1-2 minutes.
File folders load after about 4 minutes
When trying to open a folder, busy for about 2 minutes.
Message: “Location is not available.
Data Error (cyclic redundancy check)”

Only outward indication is a blinking lightbar (3-4ish/sec) connected to the smaller power/usb circuit board/bridge.

I have tried the below mentioned steps once and my drive worked for me.

  1. Go to the drive where the Windows is installed, for most users, it’s C:\Users (or ).

  2. Open the folder name with your username.

  3. Right-Click on the Desktop and select Properties.

  4. Under the Location tab, click the Restore Default button.

  5. Restart PC.