My Book Essentials 500GB drive won't stay mounted


#1

So, it’s been happening for a couple of weeks now, but has deteriorated considerably, and I haven’t gotten everything off the drive yet.  The symptom is that the drive will mount on boot up, stay mounted for up to a half hour and then cycle through attempts to mount again.  At first, it would eventually re-mount.  In fact last week it would stay mounted for up to a day at a time. This morning, it 's really hit or miss whether it will mount at all.  

I’ve tried:

Re-seating the external power and USB connectors at both ends.

Removing the case, removing the interface card and re-seating the interface card.

Putting the drive in the fridge and then on top of a blue ice pack while backing up files.

There doesn’t seem to be anything wrong with the actual drive.  My files are always there when it does manage to mount.  It’s only the USB connection that is flaky.

Suggestions welcome.


#2

Just an update on this in case any of the viewers to date are interested.  WD does not sell interface cards, and I couldn’t find one anywhere else.  The symptom remains solid, but I’ve managed to backup everything piecemeal during the times that the drive would stay mounted.  So, happy, if arduous ending.


#3

I doubt it is a problem with the drive itself. Or you would be getting lots of windows errors. Have you tried checking the event manager in control panel > admin tools for any warning errors during the mount/unmount periods?

Inside the black box is just a hard drive just like the one inside your PC. So the drive is not a lost cause. There is a few things to try.

Replace USB cable

Try plugging into different USB port

Try it on a different PC

Update the firmware of the hard drive (doubt that will help but you never know)

If all that fails, you probably have a faulty hard drive enclosure. So you can get a new HD enclosure from ebay or wherever, they are only like £10 and mount the drive into that. OR just remove the hard disk from inside the WD enclosure and wack it into your PC.

You can also get a Sata to USB adapter and use it that way.