My Book Essentials - 3TB not working on Mac OS X Lion 10.7.1 (11B26) nor Win7 64 bit enterprise

Jsut bought the 3 TB WD Essential external HDD. I plugged it in on my Mac 24", and went to Disk Utility to locate it, and get it setup. DU can’t find anyHDD. So I tested it on a laptop (brand new) that has Win7 Enterprise 64 bit on it. This installs the drivers once I plug in the HDD. Then I go to Disk management, and see that HDD is there, I right click on it, and get a pop up tell me that I must initialize the HDD before local disk manager can access it. I then select DISK1 (which is the only one in the list), select GPT (GUID partition tabel) and click OK- but get error from Virtual Disk Manager that “The device is not ready”. (I also tried MBR and same error)

So at the moment I have a brand new 3TB HDD that can’t be used. HELP !!!



For a start My Book Essentials comes formatted NTFS for Windows. I also think there is a problem with Lion and compatibility that isn’t resolved yet.


I have like I said, a brand new Lenovo X201 laptop, with W7 Enterprise 64 bit, and it also is not able to initiate the drive, ref to my first post, so no matter if it is NTFS, FAT32 or whatever, it still can’t be used. So I hope that someone from WD staff can comment on this, as this 3TB HDD is completely useless and can’t be used, either on a PC or MAC machine.

Also just tested it on a Dell D430, with W7 32 bit Ultimate, and still same error as with the other W7. So there is something VERY wrong with this product.