My Book Essentials 2 Tb won't work properly


Yesterday my WD My Book Essentials 2 Tb partitioned in half ( 1 Tb for Time Machine and 1 Tb for Media and daily usage). So I was copying some files (massive ones like 320 Gb) from it to another portable hard drive when the disk suddenly ejected and now the partitions won’t show up in finder but I can see on disk utility that they are still however not mounted. So I tried running the disk on Windows 7 and I checked that all files are still there as I was able to see the principal folders and folder size but was unable to open them as it leaded to the whole system crashing before I was able to retrieve any useful information. However, while testing I was able to copy a small .doc file from the disk to the computer, but the system crashed soon after.

So do you have any ideas of what happened? I still have 9 months of warranty however I was hoping I didn’t need to send it as I feel quite uncomfortable knowing that my personal backups and media from the last years are in the hands of a stranger.

Glad for your help

This looks like a file corruption issue.

Try testing the drive and backing up the data if possible.

You can test in the Mac or Windows. Check the links bellow.

Unfortunately I had already tried that and the drive partitions show up as not mounted. I believe there was a short power outage during night. Do you think it may be the power supply running faulty not powering the drive with constant energy supply causing it to disconnect?

If you are having power problems it can cause corruption problems if the drive is writing and gets stopped. Make sure your power supply is plugged into the wall and not the surge protector. That sometimes causes problems. I don’t know enough about Macs to recommend any software for help. Possibly something like this might help  it’s try and buy if it works.