My Book Essentials 1 TB - files missing, says needs formatting


#1

Hi - my two week old My Book Essentials 1 TB external comes up empty and “disk needs formatting” after doing a routine pc clean up and restart this afternoon.  All my files…gone.  Nothing is showing up - and yeah, I know enough NOT to reformat.  There has to be a way of recovering my files, I hope.  I have done the unplugging and replugging in already…and all it does is sit there flashing at me.   My pc sees it, but calls it “drive F” instead of F:MyBook as it did before the restart.  ANY help would be greatly appreciated, or if anyone can direct me to a source that can help?  Otherwise, I’m gonna have to sit and wait on the phone for WD tech support…grrrrrrrrrrrr.   I do have an open plea for help over at  techsupportforum  ,  no answers yet.  I did try the ‘testdisk’ suggestions already that are offered there, but i get a ‘no partition is bootable’ and can go no further.  So, I’m hoping someone in either forum can possible help me?


#2

Hey,

I have the exact same problem on my 1TB My book (Essential). I’ve had the problem for about a week but I’ve only now had time to find a solution. From research it seems most people download a partition restorer which apparently makes it better. I’ll keep you posted if I find a solution and if you find anything let me know!


#3

HI - I got a response to my questions at tech support…you can read the thread.  Seems I bought a lemon.

http://www.techsupportforum.com/hardware-support/hard-drive-support/451523-wd-files-not-showing-testdisk-says-no-partition-bootable.html

I tried the test disk program…nada.  still just sits there and flashes at me.  slows my pc WAY down now if its plugged in.  I’ve tried all the suggestions I found on the net and here…unplugging, reboot, plugin after windows is running…the dang software won’t even work properly…its just totally screwed up.   I’m taking the suggestion on that thread…I have the R studio software…to see if I can get my files back.   I have only had this thing for a few weeks…and blammo - there goes a hundred bucks and hours of my time down the drain.  I dang well better be able to return this thing.  Talk about frustrating!   Now I have another question to ask here…lets see if anyone answers this one???    Good luck to you!!!


#4

Hello, It’s strange, i have the same problem today! I lost all my data on my WD My book 1 TB.


#5

sounds a lot mine, if very slow performance and files getting crc errors and becoming unreadable is happening it sounds like the drive is dying. mine did that for a few weeks and now no longer even appears when i connect it.


#6

This has become a serious problem for Western Digital and they don’t seem to want to address this on their support  web site. People will have to take note of this before making another decision to but an external drive from WD. The very idea of losing all that important data not to mention having to buy another hard drive.