My Book Essential - Won't boot, disk "doesn't contain an EFI partition"?


So I’ve had my 2TB My Book Essential for about 2 years and it’s only ever worked on my macbook pro. I tried plugging into my PC running windows 8, and it made the sound that indicated it recognized something despite no drive popping up. I tried assigning a letter drive to it but that didn’t seem to work.

After doing that, the external hard drive doesn’t work on my macbook pro either. I get this error now - “This disk doesn’t contain an EFI system partition. If you want to start up your computer with this disk or include it in a RAID set, back up your data and partition this disk.”

I have 2 years worth of files on this and I can’t access it on either my PC or my macbook… is there anyway of getting this to work on either computer??

If it was formtted on a Mac it will not be visible on Windows without software. Most is pay like MacDrive I don’t know of any similar freeware.


Hey Joe,

Thanks for the reply, but what I’m looking for is a way for me to simply access the drive from my macbook pro now. The WD My Book isn’t accessible from either my PC or my mac, and I’m just looking for a way to make the files accessible on my mac again just so I have access to the files.

Is there a fix for the error that it’s giving me?

I’m still looking for a fix to this solution. Is there anyone that can help me simply get access to the files on my external hard drive? On either a PC or a mac?