My Book Essential won't appear on Vista x64 Machine


#1

I have a WD My Book Essential 320GB (green light).

It works perfectly fine on two of my Win XP machines but I cannot get it to work on my Vista Machine. It has previously worked on this machine, but now when I plug it in, the light comes on, and the PC makes a noise as it has recognised a USB device has been plugged in, but the HDD does not appear in device manager / computer / disk manager.

I have tried a number of things including :

  • Different USB leads

  • Different USB sockets

  • Deleting infcache file from \windows\inf

  • Replacing USBSTOR from \windows\inf

  • Running the Ext-HDD on a version of Windows 7 on a seperate HDD in the same PC (which works).

  • Viewing the Ext-HDD in BIOS (which shows it as a possible boot device, although it has no OS on it).

The same machine will mount a WD My Passsport fine, or any other external storage device…Just not My Book.

Any ideas?! Really stuck with this one…


#2

Problem solved…Seemed to be a conflict with another USB device…


#3

Which USB device?  That might be good to know.