My Book Essential USB 3.0 won't work

I recently build a new computer.  On my old comp I had an addon USB 3.0 card and the drive worked fine.  On the new comp its built onto the MB.  When I connect the drive using a USB 2.0 port it works fine. However when I connect it using a 3.0 port, the drive is detected and the unlocker program pops up, but when I try and run it I get the " you must run the unlock application from the wd smartware cd " message.  Any idea whats up with this? 

Windows 7 64bit

Intel Z77 MB


Could be that you don’t have the latest USB drivers for your MB, you can also try updating the my book firmware.

1 Like

If it was a driver issue wouldn’t the drive not come up at all? (I.E. the unlocker program wouldn’t show up?)  For completeness I did as you asked anyway and I just updated to the drivers from ASUS’s website for my board and the the firmware same issue.

Nothing?  If I call WD will they be able to assit me?

the drive and the unlocker are in two separate partitions

this issue normally indicate a driver problem as Allucard mentioned

trying a different cable should help as well

As I said I updated the drivers and still no luck.  Are there any other drivers I should try?  Also I dont currently have another USB cable just the one that came in the box.  I will get another.

I understand that its two partitions but still the same drive.  So again that reasoning leaves me wondering why the drivers would work for one partition and not the other.

Try deleting the driver then remove drive  reboot system then reconnect dtive.


I have the same problem as well, already updated the drivers, still just showing the unlocker partition. 

Same issue here, also on a Z77 board and Win7 64 bit. So irritating!

Hmm so it seems to be something with the chipset…

OK so I KINDA have a fix I went and downloaded the new drivers that were released from Intel ( V101209 ) and once I install them the HDD now works on my USB 3.0 ports BUT only until I restart and then I have to repeat in order to get it working again…