My Book Essential Problem

Need some help with My Book Essential 2TB USB 3.0.  When I first started it it seem to look fine but now everytime I start up my pc, it’s will take while and then ask if I want to format the drive.  Tried quick format and full format and it still keep asking if I want to format the drive.  I also tried update the firmware, still the same.  Please help me.

It might be a corruption problem. What OS are you using and do you always remove the drive with the Remove Drive Safely icon? Just pulling the plug can corrupt them. Look in Disk Management and see what it says about the drive there.


Use windows 7, it was like this when I first got it.  Tried three different PC and they all to the same.  It will take some time for it to show up and it ask for format.  Then a few minute later it normally again, use it as a normal storage device.

No one going to help?

try a different cable just to see what happens

the drive is too corrupted…

you can use chkdsk to test and fix the partition…

if that does not help,  replace it