My Book Essential Not Working

I purchased this drive about 6 weeks ago (2 TB) and it stopped working first thing in the morning.  I was frustrated and fairly concerned b/c it was my backup drive and I had 400 GB of video on it.

I figured that the hard drive would be fine - it was that controller.  The problem (later discovered), is that the controller encrypts the data as it is written to the drive - so - you can’t plug in a generic controller and get the data…here is the work around for that small problem

Here is how I fixed it this time…

1 Like

Glad it worked for you not everyone is that lucky… For next time keep in mind that if you have a real backup (The same data is on at least 2 separate places) then there’s no risk of data loss and no need to repair the drive, just replace it.

…finally - another enclosure arrived for the second my book essential.  This is the changeout and the riddance of WD controllers - anyone really need a working controller for this exact problem?  Post your video here and I"ll send it to you.