My Book Essential Not Turning On

I know that none of the hardware is broken, but it doesn’t always turn on when I press the button.

I plug it in, and sometimes it turns on, and sometimes it doesn’t.

It has been going on like this for a while and I would like to know why this happens.

Try plugging the power supply into the wall instead of the power strip. It may be a bad power supply.


Its been plugged into the wall the entire time, i tried other power outlets as well and it didn’t work.

To update this problem, now when I plug in the power and plug the USB into my computer, it will beep and claim it is installing drivers.

No blue light is **bleep** spinng when this happens.

I can sometimes move the cord around to get it to work, but that sometimes does not work.

It sounds like the adapter is faulty or the connector on the drive for the same. You can tested with a different power adapter , if that does not work and the drive is under warranty you can replace it.

If its the power adapter, why can my computer detect my handrive when it is plugged in, but it can’t when it is not plugged in?

If its the drive, why does the drive sometimes work?

My problem happens sometimes, so it can’t be a perment issue.

Just found out…

When I plug in both the power and the USB then press the power button, it makes a beeping sound and shows a driver install, then does the following…

USB Mass Storage Device - Ready to use

SYMWAVE Genertic USB Device - Read to use

SYMWAVE SES USB Device - No driver found

If the adapter is faulty, the drive will not get enough power for the drive to spin properly and install. If device manager s-h-o-w-s missing SES drivers you can download them from  here

Sorry for the dashes , they have inputted a new application to edit bad words and needs to be updated, keeps bleeping the words starting with s

Any idea where I could get a new adatper?

Would it be possible to use a adatper from another device?

You can use an adapter from another device as long as it has the same input voltage as the one for MB. Try the drivers first just to rule out is not a driver issue :wink:

Tried the drivers a while back before I posted this, I think its a adapter issue now.

Then if you don’t have a compatible adapter this  list will be handy for you.

Found out it was the drive itself, got a compatible adapter and it did not work.

I bought it around christmas, will it still be under warrenty?

If so, can the data be recovered.

If not, can it be repaired somehow.

You can check the Warranty  and replace it  here

Yldone, if you are using IE9 please visit the link below: