My Book Essential not recognized by Computer

This external drive was working fine until the computer was not used for about 3 months.  After installing all the Windows 7 updates on 9/20/2012, the drive is not recognized by the computer.  This includes not being seen as a drive under explorer, device manager, or disk management.  Also it does not show as a CD drive under VDR and is not found using Virtual CD Manager.  The drive is locked and I have the password but I can not use it to unlock the drive.  I tried it in another computer running Windows XP with the SES driver installed.  It was still not recognized.  I have important files stored on this drive and no way to recover them.  Have also tried changing drive power supply and cable.  When trying drive on a different computer, I am not sure if a locked drive will show up.  Does anyone have any answers?

Hi, try downloading and installing the firmware update, if that doesn’t work replace it. Click on the link below and then find your model.

Hi Alucardx23, how can I install the firmwar update when the computer does not see the drive?  Also do you know if a locked external disk should be visible on another computer in which it was not locked and has no special Western Digital software installed?

I have windows 7 64bits and motherboard asus p8-z77-v deluxe

Unplug the power/usb cables from the drive and plug them back in and the drive should be recognized by Windows.  PITA, but it seems to work.