My book Essential Not being Fully Detected on all my computers. (same message on all)


I’ve just opened mybook essential 3tb. I fallowed the instruction of plug n play but windows 7 pro 64 bits could only say *Device is ready to be use*. But their is no device to be use on My Computer.  I did unchecked hide empty drives.

Downloaded SeS but no success. Tried on USB 2.0 / 3.0 same message that it’s ready to be use but nowhere to be found.  I did some power cycles, got the DataLifeGuard Diagnostic for windows and this is the only software so far that could see this USB Hdd and it actually shows “” WD MY Book 1130 (USB)       Serial number:  ************     Capacity  0 MB    Smart Status : Not Available.  All test have been done on that software and still the same problem occurs.

ON logical Drive only my Main HDD appears but not the USB.

I tried to deep searched on all forums of WD and FAQ and found out that even in my Disk Management it shows as “” Unknown & Not initialized. And yes as soon as I open the Disk Management and ask to initialize it . In Master boor or GUID. Of course Guid is recommended for 3tb or more but I tried both just in case and this message appears “” This is device is not Ready"" . But remember when I did plug in this HDD on my PC it said on the USB drivers Device is ready to be use. I did try other places to plug in the AC and still fails. I never a HDD spinning in that BOX.

Also my intervention didn’t just stop there. I tried installing the firmware manually and notice that it shows on on the Firmware update windows that. My Book Essential SN *********** v1.0.12 and notice that the S/N is not the same on my green box and MY book Essential (Original box and HDD has same SN)  So I really don’t know if that can help but there it is. So then after I pushed Update and launch a message that I need to restart while having all apps , Av  etc… Off. So I did and still the same message. Even in safe Mode the same problems occurs. I even tried to disconnect all my ports on my PC including my  ETH cable but still no success on updating or formatting my My Book Essential.

Now I this very moment I cannot format not access this new HDD.

I have 4 ports 2.0   2 ports 3.0 but none of the ports are working with My Book…

 But I also found this while searching. This is exactly what the message on SmartWare gives me when I installed and launched .

So yes I tho my cause could of been that but the solutions aren’t helping when I’m unable to format or partition this HDD.

And now I’m stuck. So I might presume it’s defective but before conclusion. I would love to have some kind of help to point to the right direction. OR some more solutions. I got an incident number on but I feel like I got some lucky problem here.

Thanks Chris.

Take it back to the store mate…

Unfortunaly it was online retailer. I guess a RMA :frowning: .