My Book Essential Lights On Dead Stop w/o Mounting

Never had a WD go down before, so this one has me stymied.

My Book Essential. I believe it’s a 1TB or less. Haven’t had hooked up in some time but last time was using on the MAC about 2 years ago. No issues I can recall last time used. Unit was never dropped nor roughly handled. Case has never been cracked.

Have tried to get it mounted on 3 MACS: 2 IMAC and one laptop. All are running current Yosemite.

Drive has an ON/OFF panel on the back. When plugged in and turned ON, drive interior lights and front light will flash. After about 10-15 flashes, light goes solid and drive stops. I can put my ear to the shell and hear it spinning up and hear what sound like normal clicks. When the light goes solid I do NOT hear any crashing or loud click noises. Simply stops. Light stays on until turned OFF.

Tried going thru Disk Utility and nothing, though I could be missing steps here. Also have tried tanking the A/C power several times to see if that would jar it into mounting. None of the old tricks work. Drive never mounts.

UPDATE: Had the drive hooked to the IMAC. Turned the IMAC on this morning, thus activating everything connected to it. The light on the front of the drive is now doing a slow flash, but still cannot see the drive even via Disk Utility.

Just for giggles also tried hooking it up to an old PC to see if it would recognize there, but nothing.

Suggestions, please? Software or otherwise?

Thank you.


Make sure the drive is plugged in directly into a wall outlet. Also if possible try replacing the USB cable.

Thanks for the ideas. Already tried both. Unit is getting proper current and used 3 different cables.