My Book Essential Failure

My Book essential 1TB (PC) has completely failed. Several months ago, i had problems with my computer and it unexpectantly shut down several times while I was running the external. Although I was able to restart the external, gradually, I was unable to access information. It would list the files but then request a password that I had never installed. I connected it to different USB ports and that displayed the data but requested a password when data access was attempted. Finally, the light on the front would come ‘steady on’ but the computer wouldn’t recognize the drive at all. I also tried to access it on a MacBook. but nothing works. Is there any way to physically reset ‘to factory settings’? There’s only one small hole but nothing behind it to push for a reset. I’ve already backed up my PC data on another external so ‘recovery services’ aren’t neccessary. I don’t want to just throw it away (originally spent over $150 on it) and I assume some uncorrupted data is still on it. Apperciate any help.

The my book essential doesn’t have a reset button. You can try using DLG to write zeros, if that doesn’t work contact tech support to see if you can replace it. Check the link below for the steps.

Thank you Alucardx23 for trying to help me. I can’t reformat the external because it’s not reognized by the computer. However, right clicking on the ‘Safely Remove Device’ icon states it is now ‘safe to remove’ ! Prior to that, I click on the Properties tab and the vrious tabs state: The name and type of the external!!! - and - ‘The device is working properly’ - and requesting an online & computer search for an updated driver states the most recent driver is already installed!!! HOWEVER, the external is still not recognized ( = no icon) by the computer for access and cannot be accessed at all - except to be ‘safe;y removed’!!! I guess I can kiss this drive goodbye. The information was previously backed up on a secondary external, which is now primary, and it is backed up on a new secondary external, therfore, I’m junking this external with a hammer to ensure the data is never recovered.

Thanks again for your assist.