My Book Essential Disk and WD SES drivers have failed to install

Hi all,

I have a My Book Essential 2TB external HDD. For a few days its not detected on any PC and laptop i’ve connected and one of my friends has even tried it on Ubuntu, but to no use.

Its detected as a USB device

ScreenHunter_01 Sep. 20 00.03.gif

In devices and printers, it shows that the drive is working properly…but it also shows that the manufactures name and other details are unavailable.

In device manager, i see that the drive is shown up as below:

ScreenHunter_02 Sep. 20 00.04.gif

The drivers are shown to be updated

the drive is still not visible in my disk management, as it is stuck with this message “connecting to virtual disk service…”

I dont have a backup of the data and data recovery guys are asking me for almost twice the money which I spent on this drive.

Please help !!!

Tried using initializing option in the disk management…but when trying to MBR or GUID Partition Table…it says “Virtual Disk Manager…Device Not Ready”

Any idea’s on how to get my disk working and not loose data ???