My Book Essential - cannot update firmware

I recently purchased a Startech USB 3.0 Expresscard for my laptop, which I installed and which is recognised as a USB 3.0 device in Windows 7 64-bit Device Manager.

I have now purchased a WD My Book Essential 2TB USB 2.0 & 3.0 drive for back-up of my laptop.

The My Book will only connect to the laptop via USB 2.0 - not via USB 3.0.

I have tried several times to update the My Book’s firmware (connected via USB 2.0) to see if that would help, by downloading WDFirmwareupdater.exe and trying to run it, but every time I try to run the update I get an error message:

“The application has encountered an unexpected error and is now exiting”.

… and needless to say the update does not work. I have disabled anti-virus on the laptop each time I try to run the updater and there are no other applications running that might interfere with it.

Help please.

Make sure your adobe Flash and Netframework 3.5 are up to date. Make sure your notebok is up to date. Check the card maker’s site and see if there are new drivers there. The problem is likely there and not the firmware.


1 Like

Thanks Joe - I’ll check my Adobe Flash and Net Framework versions to ensure they are up to date.

The ExpressCard’s driver is the latest NEC/Renesas driver available.


Hi again Joe.

Just got home and updated both Adobe Flash Reader and Net Framework 3.5 - which triggered a whole series of Windows updates.

After a re-start of the laptop, I tried both the firmware update - still no joy - and also the USB 3.0 device connection -

sadly also still no joy. All that happens when I plug the WD into the ExpressCard is that the white light comes on on the WD, and stays on. If I disconnect the USB 3 connection from the ExpressCard the white light goes off again.

Not sure what to try next.

I saw a similar problem on another forum. Some things you might check are :

Your cable.

This turned out to be the culprit on the other forum. The person tried the drive on another persons computers USB 3 port and it didn’ t work until they  tried a friends cable. The cable that didn’t work for  USB 3 did work for USB 2 . So check your cable and drive on another computer or borrow another cable.

A few other things to check are 

Double check your USB 3 card to make sure it is connected to the motherboard . You did say Windows recognized so that may be something to check again when you have ran out of options.

Check device manager, and expand USB ports and find the USB 3.0 controller, go to properties and see if there is an error code or a yellow triangle over the icon for USB 3.0.I think you already said you checked the hard drive. You can run diagnostics by downloading  Windig, Western Digital’s diagnostic tool.

1 Like

Thanks for the suggestions. I have already tried 2 separate cables - one as supplied and another (new) Lindy cable; Device Manager consistently shows both USB 3 host controller and USB 3 root hub - neither with any yellow marks and both stated as working properly; This is the second Startech ExpressCard I have tried - I returned the first to Amazon and got a replacement. Same result with both. I will try and report back. If that does not show anything maybe I will try a different brand of ExpressCard such as Freedom. Cheers.

Hi again.

I just tried running both the “Quick” and the “Extended” Windig_124 tests, and both stopped after a very short time, with the message “Too many bad sectors detected”. Should I assume from this that the WD MyBook is defective? I have only done one (slow) back-up of each of my laptop’s C: and D: drives (via USB 2.0)?


Sorry - I just realised that I had not unlocked the My Book before trying to run the tests.

Having unlocked it I ran the “Quick test”, which it passed in < 5 minutes, and I have just started running the “Exrended” test.

Well now that I have pretty much exhausted most other possibilities (ExpressCard drivers, USB 3.0 cable and My Book) I am back to thinking about the firmware.

I note from the WD website that some of the most recent firmware updates have fixed incompatability issue with USB 3.0 controllers - which to my mind sounds like it might be relevant to my situation.

As mentioned earlier I do not seem to be able to successfully run the wdfirmwareupdater.exe.

As a re-cap, before trying to run it I suspend my laptop’s anti-virus programme, I connect the WD MyBook to the laptop via USB 2.0 and unlock the WD MyBook.

Do I also need to disconnect any other USB connections? (I have a 4-port USB hub for my printer and for a microphone), and a Logitech Unifying receiver for my mouse).

OK - I give up!

I finally managed to run the firmware update, only for the system to say the firmware is already up to date!

I tried yet another USB 3.0 cable, re-checked all devices and the USB 3.0 controller in Device Manager, but STILL no success getting the My Book to be recognised by the laptop through the USB 3.0 ExpressCard. My last effort? I am going to try an alternative ExpressCard - from Freedom.

Well I’ve been doing some digging, and it seems I am not the only one with this problem. See As you will see, like several others I can use USB 2.0 devices with the USB 3.0 ExpressCard, and USB 3.0 devices through the laptop’s USB 2 ports, but I CANNOT get USB 3.0 devices to be recognised with the USB 3.0 ExpressCard.


I replaced the Startech ExpressCard with a Freecom ExpressCard - which comes with its own power adaptor.

After driver installation and insertion of the ExpressCard I connected the WD USB 3.0 and it was instantly recognised by the laptop - BUT I got the following message: “This device will perform faster if you connect it to a super speed USB 3.0 port”.

2 steps forward…

Any ideas?