My Book Essential 3TB will not work with USB 3.0

Hey all,

 I have recently purchased a WD My Book Essential 3TB, and it works fine with USB 2.0. I’ve used it with my Mac and with my PC, and have had no problems reading and writing to it.

However, I decided to take advantage of the 3.0 speed, so I bought a USB 3.0 to PCIe cardand installed it in my desktop. And downloading and installing the4 necessary drivers for the card, I plugged in my external drive. Unfortunately, I keep getting errors with it. Either Windows 7 (the OS I’m using) alerts me that the drive has malfunctioned, that the device can perform faster if plugged into a 3.0 port (which it already is) and that the device driver failed to install.

Sometimes the drive will appear, but it will be inaccessible, as Windows sees it as a RAW, unformatted disk. Any suggestions on getting my drive to work with the USB 3.0 ports would be most appreciated.

Go into Device Manager find the drive and delete it’s driver then remove drive and reboot pc. Then plug the drive back in. That will load a fresh driver. Also check in BIOS and see if the USB 3.0 needs to be enabled there. What make is the USB card you installed? USB 3.0 is a bit buggy from what I can see. It wasn’t a well coordinated project between hardware and software people.


Thanks for the quick response Joe.

I checked the BIOS and ensured that USB 3.0 is enabled. I also deleted the drive’s driver and reinstalled it after a reboot. The USB card make is - if you couldn’t tell from the link I posted - is a NEC model. It didn’t include any driver CD with it, so I’ve had to go online to find it, as Windows doesn’t hold any 3.0 drivers by itself. Renesas seems to be another company that works with NEC, according to a few websites I’ve visited. I’ve tried multiple drivers, including the NEC 3.0 Host Controller, the Renesas Host Controller (which I’m using right now) and I’ve installed the WD SES driver.

EDIT: I fixed the link to the card in my original post. It was linking to an incorrect web page.

Well I deleted the USB 3.0 driver and shut down the computer. Then I removed the PCIe card and plugged it back into another slot. After I rebooted, Windows identified the driver as the Renesas one I had installed previously. It works fine with USB 2.0 devices now, but when I plug in the WD My Book, it gives me mixed results. Either nothing happens, or the message “this device can perform faster if plugged into a Superspeed USB port” appears, but it does work. I’m not sure if it is still giving me 2.0 speeds or if the 3.0 card really works.

I realize now that I don’t have SP1 installed for Windows 7. I haven’t been able to, because it gives me an error message that some system components are missing. I’ve read that SP1 adds USB 3.0 support to Windows. Might this be the answer? If so, how would I get SP1 installed? Just a repair install, or would I have to make a clean go of it?

For the Windows SP1 issue you may need to run the MS system readiness Tool It might fix the problem with the update. I had to use it on my sister’s Windows PC to get SP1 to run. You might also want to download the stand alone version of SP!.


Thanks for the suggestions Joe! I did run the MS System Readiness Tool, and it download and installed a hotfix for Windows (KB947821). However, even after a reboot, the service pack wouldn’t install. I even tried the standalone version of SP1 as well, with no luck. Maybe I should just do a clean install of Windows, install SP1, and then try using my USB 3.0 card?

Since SP1 still won’t install the problem with the drive could be in Windows. Do you have an actual Windows install disk or just the recovery software? The restore media will take you back to the new state and all the crapware the factory installed. If you have an actual Windows disk you could do a repair install. Let me know what you’ve got there are a few different things you can try.


That’s right Joe; I haven’t given up hope yet. Although reinstalling Windows is obviously the last desparate solution, it will be easy because I do have a retail copy of Win 7 Pro (this was a custom built computer, not an OEM), so I should be fine with the activation as well.

I could try a repair install, and that is probably the next step I’ll take. I have run sfc /scannow and it reported errors, but said that Windows couldn’t fix them automatically. I checked the CBS log files that System File Checker generated, but I can’t make heads or tails out of them.

I’ve also contacted the seller on eBay. Of course, it had to be a vendor from Hong Kong, so it’s doubtful I’ll get a response as to what software or drivers I need for the card. But let me try installing SP1 first, and if that doesn’t get the USB 3.0 working, then I can always return the card and buy a different one. 

Ok since this is a custom build this might work better. Go to Didgital River, this link has a description and the links so you can download Windows 7 With SP1 integrated . Use something like Imgburn and keep burn speed at 4X or less. Also get free Belarc Advisor  that will show all of your installed software and their activation keys. One more thing to try before reinstalling is run Startup Repair at least 3 times. I know it sounds strange but I see the run 3 times recommended by some smart people. In all honesty USB 3.0 looks buggy and poorly coordinate to me. It doesn’t look like the hardware makers and MS did enough colaboration before releasing it. I always partition my drive with system and programs on one and data on the other. Then you can reinstall system and your data stays. Hope this helps.


Thank you for your suggestions Joe; I really appreciate your efforts in helping me fix this problem.

OK, I downloaded and created a disc with SP1 integrated, and I burned it successfully. I also ran Startup Repair 3 times, and you are correct: I have heard on several forums that 3 times really is the charm with Startup Repair! Unfortunately, it didn’t help. :( 

I also opened msconfig and did the following: 

  1. in services tab: 

a. check “hide all microsoft services” 

b. clicked “disable all” 

  1. in startup tab, clicked “disable all” 

  2. reboot

but to no avail either. It seems that whatever the heck I did to my system, Windows really doesn’t like it!

It appears that I will have no choice but to do the repair install. But I have a couple of questions about it before I begin:

1.) I thought I couldn’t use an integrated SP1 disc to do a repair install. Aren’t I just supposed to use my own retail, non SP1 disc to repair an installation that doesn’t have SP1 installed? Or will the integrated version work with my non-SP1 installation? Maybe I’m confusing integrated with slipstream.

2.) I tried using my retail Win 7 disc, and I ran into a snag. After I clicked the “Upgrade” option, I received a dialogue which stated that, “Windows Professional cannot be upgraded to Windows Professional.” I thought I was just doing a repair install? But for some reason, when I select Upgrade instead of Custom, the installer will not let me proceed. Very strange!

I think you are right Joe: this whole troubleshooting business is getting out of hand. USB 3.0 should be plug and play! Maybe I just got the wrong card.