My Book Essential 3TB not recognised by computer

I have read the sticky on this problem, but to no avail.

Problem: When I plug my My Book Essential into the USB 3.0 ports in my computer, the drive spins up and power LED lights up, but there is absolutely no response from the OS whatsoever.

Steps I have taken:

  • I have ensured the USB 3.0 driver for my motherboard is installed (and have reinstalled it)
  • I have uninstalled and reinstalled the WD SES driver
  • I have successfully used another USB 3.0 device in the same USB 3.0 sockets (a WD My Passport)
  • I have switched USB cables (same result)
  • I have plugged the My Book into a USB 2.0 port on the same computer. It is then recognised, however this is obviously not ideal as it is only operating at USB 2.0 speeds.
  • Fiddled with BIOS settings (HPET, USB storage)

This drive *has* worked with this computer at some point in the past over USB 3.0, but there have been several reformats/reinstalls of the operating system since then. I am running Windows 7 x64 on an i5/1155 based setup.

The fact that it works over USB 2.0 but not 3.0 would suggest possibly hardware problems in the drive or the PC, or a driver issue. However, the fact that the My Passport successfully works over USB 3.0 rules out the hardware issue on the PC, leaving, as I see it, either a hardware issue on the drive or a driver/software issue on the PC. Any help would be appreciated.

1 Like

when you check on the usb 3.0 host controller… do you see the drive with an exclamation mark?

this sounds like a driver issue… the fact that the drive works on 2.0 makes it look more like a compatibility problem…

are you certain that you have the latest driver available for 3.0? 


Nothing appears as connected to the (Renesas) USB 3.0 host controller. I’ve downloaded and installed the only driver available from the Gigabyte (motherboard) website.

I think I’ll just get the data off it from USB 2.0 and RMA; hopefully the replacement won’t have the same trouble.

sounds like a good deal to me…

hopefully the next one will work

do an advance rma just in case :wink:

1 Like