My Book Essential 3tb is not being recognized

I plug my external harddrive into my computer and my computer recognizes that something has been connected and under devices it shows up as My Book 1140 but when I go to my computer there is nothing.  Nothing shows up so I can not get into my files, I don’t know if they even still exist on my harddrive!  It normally shows up as F drive, but nothing comes up.  The drive is also making a weird clicking/whiring sound, though I did not drop it or anything…  Could I have had a power surge while I was sleeping and it messed the drive up?

So, any ideas on how to get access to my drive gain?

Check if the drive appears on disk management

if no important data , reformat the drive

try running a firmware update

1 Like

I noticed my problems began with my drive not being recognized in My Computer after I installed the newest firmware. Was recognized before that.

I have the same issue.  I updated the firmware, then my laptop couldn’t recognize the drive.  In drive management, there is no letter associated with the WD drive, and I am unable to assign one.

I’m not sure what to do now.

The first time I updated the firmware I used the firmware version that came as part of the software that was installed on the hard drive.

After having problems with that firmware upgrade I went to their online site and tried their Universal Firmware Updater and tried that. It seems to be the same version number that I had already installed but my Hard Drive has since been recognized and everything works fine.

Here is the link:

I hope this works for you.