My Book Essential 3 TB - PC - Very slow backup

Last week I bought an external hard drive WD My Book Essential 3 TB (3.0/2.0 USB) at Costco to use with Windows 7 Home Premium  (HP P6787C - AMD Phenom™ II X4 840T - Processor 2.90GHz with 8GB RAM - 64-bit Operating System).  I am using a Segate external hard drive 2TB as my main drive and using My Book as a back-up.  I have all the latest updates for the drives. I have two problems:

#1 -  I am experiencing very slow backup speeds.  I am trying to backup 600GB worth of files.  It has taken My Book (using WD software) 4 days to copy 235GB.  

#2 - Last night I received a message that WD My Book had to close.  When I re-started the software I notice in the Backup tab a message on the far right stating “Files Not Backed Up - 116,696 - Size 361.74GB.”  It has been running all night and this morning but no files are being backup.  It is still showing 235GB worth of files backup.  I am not sure what to do.

Please advise me.  Thanks

Are you using your new MyBook Essential on a USB 3.0 port? You might have it plugged in a USB 2.0 port.  That would explain the painfully slow speed.  You will get about 1/3 of the drive’s maximum speed on a USB 2.0 port vs. USB 3.0.

Then again, it sounds like you’re not even getting that much speed.  600 gigabytes in 4 days works out to about 7 megabytes per second.  USB 2.0 can sustain around 33 MB/s so something doesn’t sound right here.

There may be more to this, however.

I bought exactly the same external drive at Costco a couple of weeks ago, and I can’t get it to connect to a USB 3.0 port at USB 3.0 speeds. It connected as a USB 3.0 device for about one day.  Since then, it will only connect as a USB 2.0 device, even though I am plugging it into a USB 3.0 port.  I’m starting to wonder whether there is some sort of fault in this particular model of MyBook Essential, or perhaps with the supplied USB 3.0 cable.

I bought two machines to keep lots of safe AND fast backups with a new PC.  Nope, seems there is a timing error, backups always seem to work, but verifications and restores “lose the path” and sometimes a verification can be restarted, but a restore in progress yields trash.

The drive works fine in 2.0 USB mode.  The motherboard (Gigabyte Z68XP-UD4) has the latest BIOS upgrade (did not good).  It’s a 2TB My Book Essential, not 2GB not 3.

Anyway there seem to be timing problems acknowledged just a bit by Gigabyte; but I see no WDC employee jumping in and saying anything about the inability to use 3.0 (which IS fast) without timing out and failing.  I have the power savings stuff all turned off, the USB section shutoff disabled in Windows 7.  I’ve seen no responses of any kind by WCD reading through these messages - anyone?  (As a test it will do tiny backups correctly, but will fail at some point in 300 gb restores or verifies.  I’ve asked Gigabyte for a response, and of course, so far, nothing…


Thanks for the tip.  I am new to this.  How do I find or determine the 3.0 usb connection in my PC?  I just plugged the usb in the back of the computer.  thank you kindly.

USB 3.0 ports will sometimes have a “SS” marking nearby (for “SuperSpeed”).  Also, there is usually a bit of blue plastic in the port.  USB 2.0 and older ports never had a standardized plastic color, but all the ones I have seen were white, black, gray, or some color other than blue.  You might want to read up on USB 3.0: Wikipedia article on USB 3.0

Also, you can look in Device Manager under the “Universal Serial Bus controllers” section to see whether you have any USB 3.0 devices in the system.  For example, my USB 3.0 card has the items “NEC Electronics USB 3.0 Host Controller” and “NEC Electronics USB 3.0 Root Hub” associated with it in Device Manager.

It would help to know what kind of computer you’re trying to use the drive with.

Thank you for the enlightenment.  The information for my computer was in my first posting.

Good news!  I was able to correct the problem last night. I tried a few things around mid-night and by 7AM the WD My Book hard drive copied 364GB and my back up was complete.  Here is what I did.  I have a brand new  (HP P6787C - AMD Phenom™ II X4 840T - Processor 2.90GHz with 8GB RAM - 64-bit Operating System) running Windows 7 Home Premium.

  1.  I went to Device Manager then selected the Seagate Hard-drive in the Disk Drive section.  Then  I went to properties for the drive and changed the setting in Policies - Removal Policy from Quick Removal (default) to Better Performance option.  Then I did the same to WD My Book hard-drive.  Then it said I had to restart for the changes to be made active.  So instead of restarting I shut down the computer.  

  2.  Once the computer was fully shut down and the external hard-drives were off. I have two USB bays in the back of my computer.  So I moved the Segate which was in the lower USB bay and put it in the top USB bay where the WB MY Book hard-drive usb is located.  Then I started the computerand ensured my drive letters did not change which they did not.

I did not notice anything different as to speed but it did have to re-locate the drivers for the changes I made.  I ran the WB My Book backup software to ensure everything was pointing to the right drives.

I went to bed which was after midnight and in the morning around 7AM the WB MY Book had copied 364BG worth of files and everything was fully backed up.

Thank God!

If anyone is wondering.  My computer only has 2.0 USB ports.  thank you again.