My Book Essential 3.0 (3tb) doesn't load

I bought mine a couple months ago, worked flawlessly till just afew days ago… Stopped showing up on my computer. I’ve tried a change of cables and power adapter to no avail. It shows up in disk management, but is not initialized. I can’t initialize it or anything. It always give the device is not ready. And WDSmartWare is always Drive Discovering. It shows up in the BIOs as well.

The light is always stable, no blinking or anything. I’m not sure if the drive is spinning…

Please help,


Are you plugged in directly to the wall outlet? And what power adapter or cable are you using right now? Try using the original cable and adapter and plug the drive on another computer with a different operating system. You can check the problems of the drive this way especially if there is a detection problem.

I tried plugging into the wall outlet as well. I tried with a extra power adapter & cable but regardless of combination with the originals. Didn’t work. Also didn’t show up on my other computer, same problem.