My Book Essential 3.0 2 TB doesn't work on desktop, but does on laptop

I have a problem with my newly bought My Book Essential 3.0 2 TB. I first used it on my laptop and it worked great, the installing went quick and simple, and since then it’s been working just fine. The problem appeared when I connected it to my desktop: the installation didn’t complete because the wizard couldn’t find a drive for the HDD and the pop-up window said it might not work properly. It did!

Ever since every time I connect the HDD to the desktop it doesn’t appear in My Computer (I’m running Windows XP SP2) and it freezes everything (nothing shuts down, every window showing content of the internal HDD stopps responding, and when I close them the explorer application goes down and I’m left with the Desktop Background and forced to restart my PC manually).

I looked into Device Manager and when I connect the HDD it shows in disk drives, but it says it doesn’t have a driver. After a few seconds the screen flickers and it says the device is working properly, but it still won’t appear in My Computer. Finally every window opened starts Not responding and I have to restart. I looked in Device Manager and found the SCSI and RAID controllers in conflict with something ( it has a yellow circle with a exclamation mark in it ).

I uninstalled this and connected the HDD again, the new hardware wizards appears and now it finds a driver, but it can’t install it properly, no matter if I try installing it of the Internet ( I went to the WD site and got the SES Driver) or I let it search for a driver.

Now I have a working IDE controller in the SCSI and RAID controllers ( I created a SCSI drive using Deamon Tolls ), when I connect the HDD it appears in Disk Drives with a working drive but it still doesn’t show up in My Computer, and after a while the freezing process begins and finally I restart the desktop manually. The My Book HDD appeared once it My computer, about the 4th time I connected it, but when I explored it’s content the window stopped responding and I had to restartand after that I never made it show up in My Computer.

Sorry for the long tale but I tried my best to explain what’s happening. Does anybody have an idea on how to solve this problem? Did anybody have the same problem with their My Book? I really hope someone can help me because I need to use the HDD on my desktop.

Thanks, ComanV.

have you tried connecting it to your xp machine using just the usb 2.0 cable?  try that.   and do you even have usb 3.0 on your xp machine?  if not, then you may be experiencing a hardware conflict.

First of all I only have one cable, used for both 2.0 an 3.0 USB. On my laptop I’m sure I’ve got USB 2.0, but on my desktop( an older but still good computer) I think it’s the older version of 2.0, 1.1 I think. But I don’t think that should be a problem because the HDD should work with 1.1 USB, only on 1.1 USB speeds.

First I would suggest updating XP to SP3 and eliminate that as a possible cause.


For that I think I need to reinstall Windows. The thing is that on my laptop only today I updated to SP3, till today it was running SP2. In the next days I’ll move everything I need from the desktop and reinstall XP with SP3, but I don’t think that should be am issue. People using Win 2000 are using this HDD, also those running SP2.

I’m still not sure I’m understanding how you are connecting to the desktop.  did you install a usb 3.0 card, or are you just connecting to any usb port?  you have to have a usb 3.0 port for the drive to work at 3.0 speeds.  and obviously something is going on with your computer if you’re having hardware conflicts.  how are you connecting to the desktop - standard usb port or 3.0 card?

@ Joe_s I’ve updated my OS to SP3, and it’s exactly the same issue. Nothing changed.

@ Wayne I’m using a standard USB, I don’t have a 3.0. The problem isn’t the speed it’s working at, it’s the not working at all part that bothers me :). As I said on the laptop I’m sure I have 2.0 USB, but the same file transfer takes longer on my desktop so I assume it’s older than 2.0 ( it’s not really my desktop, I just use it ). The part with the conflict has been improved, I no loger have that yellow circle wtih " ! ", but a device that is working properly.

Still, every time I plug the cable in the USB the HDD starts reading, the light flickers, and finally when it should show up in My Computer, it doesn’t! Every window stoppes responding and I have to restart manually.

Update: I managed to connect my HDD to the computer and it works fine, shows online in device manager, healthy, I can view and write files on it but only if the HDD is connected to the desktop before I start it up. If I disconnect it and reconnect it everything freezes and I have to restart manually, and if I leave it pluged in when it restarts everything is just fine, speed of transfer is really good… basically it work OK. Anybody know why this is happening? Why can’t it work when I plug it in while the PC is on?

Have you tried updating the drivers in the USB controlers?


I tried and there’s no better match.

I tried and there’s no better match.

Try powering the PC down and unplug from power it for about 15 min. Sometimes this resets something in the BIOS. I can’t think of much else.