My Book Essential 2TB

I recently bought a 2TB My Book Essential USB 3.0. About 2 weeks ago i unplugged the My Book to move it and when i plugged it back in it showed up as a Local Drive G: and then it says if i want to format it. I do not want to format it until i try other solutions. I am currently using it on Windows 7. Also It was first used on my desktop with vista but i no longer use the desktop so i just use it with my laptop now.

Also under disk management it says RAW instead of NTFS.

It sounds like the partition data is corrupt. You can try TestDisk or Partition Find and Mount . As a last ditch you can try the Windows command to change format from FAT32 to NTFS that sometimes fixes it too. Here is a link for that I’ve seen that fix posted by some smart people.


Thanks for the help.  I tried the FindandMount option and it could not find any partitions at all even with the comprehensive scan. I also tried TeskDisk but could not get that to work either. I will try TeskDisk again maybe i did’nt do it right but is there anything else?

You can try a Linux Live CD and see if you can get data off or data recovery software like Recuva. There are a lot  of them some are free others try and buy. Then there is the command I mentioned it’s in the middle of the page on MS link.