My book essential 2tb stop working with USB 2.0 ports but it keep on working with usb 3.0 port

hey guys,

i’ve been using it for 4 month i think, and it worked just fine.i have been using it with usb 2.0 ports.

suddenly it stopped working with my usb 2.0 ports!

at first i tried some “first aid” like trying it over all my usb ports (when nothing else is plugged) i also was cheking the bios looking for changes in the USB category. none. 

I took the drive to my friend, we plugged it to usb 2.0 port- nothing.

we tryied it over 3.0 port- and it worked! all files are saved.


1.when ive plugged the disk to both computers to USB 2.0 - no sound of pluggin somthin.

2.i can’t see it on my “disk manage” options.



last chance guys…i can’t work it out!

somone has it too? 

well, i have posted this question also in the WD support, and nothing! not a single answer.

pleas guys, i’m hopeless.


Since the drive works on USB 3 but not on USB 2 I would suspect a problem on the USB 2 port on the drive. I see you tried a lot. Are you using a cable longer that the one supplied and have you tried a new cable>


hey joe,

thank you for your replay,

no, i wasn’t trying connect with other cable, just with the one supplied.

i will try a new one.

WD Service contact me, and we work on a solution, i will update if there’s anything new.

thank you !

hey guys,

well, i’ve tried it with other cable. nothing.

Plugged it into my friend’s computer that having usb 3 ports and run the diagonastics tools- all OK and still- not working in the usb 2.0 port.

any wize advice someone?