My Book Essential 2TB - installed but now my PC is very slow and I receive many error messages


#1

I have a generic PC that runs the XP Home Edition @ SP2 with 523M of RAM. Things ran quite well until I installed the MY BOOK Essential 2TB firmware and smartware. The installation of the WD firmware and the software went as advertised. No problems there - I even updated the software to the latest version as suggested. Things looked good.

However, now that the WD SmartWare is installed, it takes about 2 minutes for MS Explorer to load or a minute for my email program to start. Other programs seem to take forever to load as well. If my McAfee update automatically starts, I might as well go watch TV and come back in 20 minutes. Previously I could do work when McAfee was updating. I am also getting many different error messages that I have never seen before. 1. WD Drive Manager has encountered a problem and needs to close. We are sorry for the inconvenience. 2. My Book (G:) This disk or device contains more than one type of content. What do you want Windows to do? 3. WD SmartWare has encountered a problem and needs to close. We are sorry for the inconvenience. 4. To free up disk space, Outlook Express can compact messages. This may take up to a few minutes. and this one: 5. The system has recovered from a serious error. 6. There were a couple of other error messages for a Creative Sound Card and my Logiteck keyboard.  

Has anyone else had these problems with their WD SmartWare? Should I delete the WD Smartware and reformat my External Drive or is there another way of solving these problems. Since joining this Community, it looks to me like many other people have had these problems and they have returned their unit.  Is it that the Smartware is just too CPU intensive due to bad programming and I should remove it?