My Book Essential 2TB, Delayed Write Failed, RAW Disk, Unreadable, then Unallocated...HELP!

I bought two 2TB My Book Essential (WDBACW0020HBK-00) drives a while back. Both worked fine until about a month ago. One day one of the drives gave me a “delayed write failed” error. I tried to disconnect the offending drive via the “safely remove hardware” dialog, but kept getting the drive is still in use response. The on/off button on the back of the drive did nothing (I held that button for over a minute). I then immediately shut down my computer and disconnected the drive. When I powered up I reconnected the drive but it did not show up in My Computer OR Disk Management (it shows up as “WD My Book 1130 USB Device” in Device Manager). After a second reconnection the drive showed up as “Local Disk (G:)” Instead of “My Book (E:)” with a RAW file system and a capacity of 0. I tried changing the drive letter in Disk Management but there is no option to do so. The disk simply shows up as “unreadable” with no drive capacity. Plugging the drive into another computer provided the same result.

After searching this forum (and nearly the entire internet it seems) I found some individuals who were able to recover their data by replacing the enclosure. Luckily I had a second drive of the exact same model number so I took a chance, opened the enclosures and swapped them. No luck.

About a month before the failure, I purchased a third 2TB Essential (WDBACW0020HBK-01) to be used as an internal drive. Out of desperation, I took that already opened enclosure and tried to revive my drive. It showed up as unallocated (no surprise) but it did show the correct drive capacity. I did a SMART scan of the drive and it passed all tests. My questions are as follows:

  1. Was the SMART scan compromised by not being in the original enclosure?
  2. Is there a problem with the drive or enclosure that can be fixed (firmware, partition repair, etc)?
  3. Why would the drive not show any capacity when in the original enclosure but show an accurate capacity when in the newer model enclosure?
  4. Is there any way to recover my data without taking out a second mortgage?

Thanks in advance.

Did you first check if the hard drive was under warranty? I would have tried connecting the internal hard drive directly to the PC and then try to format it from there.

Unfortunately, the drive is no longer in warranty. I really want to avoid formatting the drive until I am 100% sure that my data is unrecoverable (without breaking the bank, that is). The fact that the drive shows the correct capacity when outside the enclosure gives me hope. I know that the data is hardware encrypted en route to the drive; perhaps the link between the enclosure and the drive itself (encryption?) got fouled up and is denying access? Thanks for your help.

Don’t know if it will work, but you can try scanning the hard drive with a data recovery program like recuva or testdisk.