My book essential 2tb 3.0 wont do anything on computer, cant view files

 ok my book was replaced about six months ago with a brand new my book. It now wont read on any computer and i cant play movies i have on there. what should I do?  it shows it is loading on computer and spins like its supposed to but last time it played it said i had corrupt files on it. please help thank you

If you connect your drive to another computer do you encounter the same problem? How about a different USB cable?

What OD are you usong and does the drive show in Disk Management?


yes i tried both a  different computer and a different cord. I can see terabyte but cant access it or look at files on it.

my computers both are running windows 7

Did you try it in a USB 2.0 port? Does the drive show in Disk Management? Look down wher drives are shown as bars does it say anything there like Raw?


QUESTION: why was your initial drive replaced?


DIAGNOSIS: Faulty USB port within th external case… endemic fault  within the 2TB/3TB external “book” series… check the posts by Joe_S and fzabkar for more information…

i tried in the 2.0 port shows up but cant see what file is on there. i also tried disk management showed the terabyte and how much space is available still cant look at the files on the terabyte