My Book Essential 2 TB on Mac and PC are not readable

Hi there,

I’ve had My Book Essential WDBACW0020HBK-01 for 3 years now and its been working perfectly (reformatted to FAT) used for Movies however I’ve just tried to use it on both my MAC and PC its saying that “the disk you inserted was not readable by this computer.”  I’m presuming it wants me to re-partition or format it but that will mean I will lose everything thing right?

I haven’t dropped it or disconnected without ejecting so I’m not sure why this has happened. I’ve also tried it with another power cord and USB cord without any luck

Has anyone else experienced this and is it just due to a software out date.

If nothing can be done can I take it to a software person and they can recover the files? 

Any help would be wonderful as I’m not really sure what I’m doing.

Thank you in advance.

If you connect the drive to a windows computer, are you able to see the drive under disk management?

If nothing can be done can I take it to a software person and they can recover the files?

Yes, there are many data recovery companies that might be able to recover the information for you. Also you may try with a data recovery software.

I have 2 My Books and 2 passports and NONE of them is readable on ANY computer, either desk top or disk utility. All have been safely stored and not bumped or undergone any physical shocks. These are **bleep** devices - or else apple is planting malware to ensure they don’t work with their products.

Either way - complete waste of time and has cost enormously in lost movies and music, not to mention purchase prices of HDs.