My Book Essential 2.0 WD 5000h1U-00 No lights, no icons, nothing!

For a period of time I would get the message that the external drive had been removed inappropriately, after which the disk icons would show up, then disappear, then the message would return, then the icons would again show up, and then disappear again. [I was actually able to quickly load up a file and copy it once.]

Now when I try to plug it in there is nothing. I have tried 2 computers, 2 USB cables, and I cannot find a replacement power adapter to try. 

Any ideas? Can someone like the Geek Squad get the data off for a reasonable rate? 


Is the power adapter directly connected to a wall outlet? If not then try it.

Here’s a list of specs for power adapters

There is no power adapter listed for my My Book Essential. I looked at ALL the power adapters and none had my model number listed.

I tried 3 different wall sockets without any luck.

Thanks for the ideas – they are much appreciated!

I found the problem, I think. The power adapter was bad. I bought a replacement from for around $12. I’m going to migrate my files to another external hard drive.