My Book Essential 1TB USB 3.0 External Hard Drive not recognized

I just got a new laptop with Windows 8. It does not recognize my external hard drive. I have been able to get it recognized, briefly, by some voodoo combination of unplugging/replugging the usb cable and power cable and praying, but it did not last. I experienced a similar problem with a friend’s computer (which used Win7), but I discovered that the problem was only with the USB 3.0 port, and it worked fine on the other ports. I’m not even sure that I have a USB 2.0 port on the new laptop. Note that my last laptop (Win7) had no problems with the hard drive, and neither does my current desktop (XP).

Also the unplugging voodoo trick only worked on a single usb port. I suspect that this is the only USB 2.0 port on the laptop; the other three all have the SS logo associated with Super Speed USB 3.0 next to them.

Hi, check if you have any USB 3.0 driver updates for the laptop and also check for any firmware updates for the my book. 

Hi Alucard, I hate to sound like a newb, but could you explain how I would do that? I don’t know how I can install firmware updates to the external if the laptop does not recognize it, and I flat out don’t know how to check for driver updates.

No prob, for the laptop USB 3.0 drivers you need to go to the laptop manufacturer web page and find your model to view the available downloads. For the my book firmware, click the link below and select your model to view the available downloads.

Here is the problem that I run into with the firmware updater: it keeps asking me to unplug and reconnect the drive I wish to update. I have no options but “Rescan” and “Exit”, which tells me that it is not detecting the drive, again pointing to my previous question of how I install firmware for a drive that the computer does not detect.

Well if the PC doesn’t recognize the my book when connected to the USB 2.0 port, you might need to connect it to another PC. Did you check if you had any driver updates for the laptop?