My book essential 1tb external drive

OS Windows 7 Pro32Bit

 Explorer does not show my WD 1TB External  Drive   in the Drives list.

Same happens when I use PowerDesk. explorer

I can see the drive using Disk Management - It is in ONLINE mode.

I am unable access any of the files .

Recently changed over to a new Computer from an old one which used XP OS.

It did worked great on the old  Computer.

Any suggestions?? Thanks


Can you post a screenshot of the Disk Management screen? 

Bad news, if you jumped from XP to W7 then you’ll likely have to format the drive since you mention it is online.

I bet that even though it’s online, it doesn’t have the NTFS file system or a drive letter…

Try a Linux Live CD and see if you can access it that way. It doesn’t actually install anything. you might be able to copy data off ot it.


In disk managment it shows following 2 drives:

N 930.86 GB NTFS - Healthy (Active Primary Partition)

M WD SmartWare 668 MB UDF

Healthy (Primary Partition)

But I still cannot access"My Book Essentials external Disks" thru Windows or Power Desk 8 explorers.

In disk managment it shows following 2 drives:

N 930.86 GB NTFS - Healthy (Active Primary Partition)

M WD SmartWare 668 MB UDF

Healthy (Primary Partition)

But I still cannot access"My Book Essentials external Disks" thru Windows or Power Desk 8 explorers.

Read my first post.

My WD My Book Essential 1T showed 2 drives

namely n and m one drive has ntfs files system the other has uad file (this probably has WD Smart stuff.

Anyway I reformated the NTFS drive as suggested (fortunately I didn’t need any data wiped off)

Anyway problems is still with me.  I can see the drives in Disc Management>

I still cannot access the the My Book from Windows Explorer.

From what i can gleam from the Internet It is a widesprfead problem.

Could be a Windows 7 problem  as the thing did work ok when I ran it from my old PC using XP.

Would think WD should give this some serious thought.  I’ve put more time trying to solve this.

All my lower Capacith storage work just fine.

Thanks for your thoughts.


excuse sorry to disturb u dear actually i lost my (my book) power adaptor kindly tell me what is the specification of power adaptor or my book 1Tb external power…?



This should help identify the power adapter 


To review the problem of not being able access WD external MY Book Essentials on a PC with WIN 7 pro.

I have tried this HD on two older PCs with XP OS and both have worked just fine.

I also tried another external drive a  Kaser Storage Vault(which has a 250GB  WD Drive inside) and it presented the same identical problem of not being able to access the drive through Win7 Explorer  .

There was no problem seeing both drives in Disk Management. It does appear to be a problem associated

with Win 7 Explorer.  Formating does not seem to be a solution as all data is wiped out. ( I have tried this

suggestion  on MY Book drive to find it does not solve the problem. I can still access thru the XP PCs but not Win 7 PCs

There has to be some data on these disks that is not being recognized by win7 so it can be accessed thru explorer. 

Higher Intellectuals should weigh in on this one—


LATEST: My Book Essentials not being recogonized by Win 7

Went out and bought a program (paragon) to have a better look at this problem namely

My Book Essential not showing up in Explorer on a PC using  Win 7 OS .

It does show up ok on 2 other PCs which use XP OS with all folders etc. (after copying content to the drive)

The program which I used on the PC running Win 7 showed all content in its Disk managemnent portion.

So everything is on the Disk but Win7 still does not show in Win Explorer.

As a last resort tried do a firmware upgrade on the Win PC with following msge

“Application encountered an unexpected error and is now exiting” 

Mine is not a unique problem  I have an identical  situation with a 2nd external drive namely a

KASER 250GB Stoirage Vault which has a WD HD in it. (not under warranty)

I have yet to see any interest from Western Digital in this problem -

I thought they might be monitoring these forums???


This is just a users forum not WD support. If the drive works on XP but not in Win 7 I’d look there for a problem. In Windows 7 does Disk Management show that the drive has a letter and is online? Does it say anything there about the drive indicating a problem like raw? Did you check the sharing/permissions in Windows 7? They can cause a lot of trouble. The sharing is a pain to work through I’m a single user so I allowed full permission for Everybody so I could access it from my other PCs that are networked.