MY BOOK essential 1 TB does not turn on


#1

I just bought a new MY BOOK essential i have tried it at the store and it was working fine and already installed the driver , now when i came back home i  plugged the HD but i got no power signals or any sign of it connected , all what i see is just a small blinking in the front leds i tried the power button and restarting the laptop but nothing happens . please help me or should i go back to the store???

thanks

Sam


#2

Hi,

Try Using the drive in the wall socket directly instead of Surge Protector. :slight_smile:


#3

I am having pretty much the same problem.  The My Book was plugged into the wall and the power source was accidentally unplugged from the back of the My Book.  Now when the My Book is plugged in, no leds come on and my mac computer does not recognize it.  

I am wondering if the power loss may have damaged something? Also, is there a way I can get the files off the My Book External hard drive if it will not turn on?


#4

Any fixes for this yet? I have same problem


#5

Was the driver installed on the computer you are now using or was it a different computer?


#6

Sad to say but I have the same problem and it is using the same computer.  I must admit I’m very disappointed.