My Book Elite Firmware Updater Mac problems


#1

On my second drive in less than a month…

WD Smartware says there’s a new version so I update that. But you can’t disable the virtual cd without updating the firmware. I followed the firmware instructions exactly as described on the website. This is what happened both times:

http://cld.ly/3c1nn3

The light is only half bright (it fully brightens up when pressing the power button) and the display is scrambled. Tried it on several Macs and none recognize it, not even in Disk Utility. It seems to not even boot up.

I have an RMA out on this one, but I’m hoping to at least pull some data off of it first.

I’ve unplugged the USB & power multiple times along with the Mac. Any suggestions?


#2

Ok, fixed it.

Here’s a tip for anyone with a Mac or the WDC Technical Support: DO NOT UPDATE THE FIRMWARE THROUGH OS X.

That only messes up the drive. If you run the firmware through OS X like I did, boot into Windows and run the firmware update. What do you know, it updates correctly and works now both in Windows and OS X.

Hopefully this will help someone else one here as well.


#3

What if i don’t have windows? I’m only have Mac OSX which was the first reason why i got the My Book Studio 1TB (WDBAAJ0010HSL). Any solutions for that? Tried the latest software update (1.2.1.25) which then required me to update to the latest firmware as well, and i can’t. Somehow when i select the feature to update firmware and nothing happens. have tried manually downloading the Elite firmware update and the old Studio Turbo drives as suggested by WD Support but to my excitement it failed and nothing happened as well. Initially i was under the impression that this product was built for Macs, therefore mac friendly and also as advertised and highly priced as well, it came with a beautiful firewire 800 feature, which doesn’t work at all, so now i’m stuck using the slow USB cables for my graphic works. Sorry if i sound crazy, just a little frustrated that I bought something which doesn’t work, spent like half of my salary on this.


#4

Know anyone with a Windows machine to take the drive to? Or can you setup Bootcamp with Windows?

I’m with you, I’m disappointed that WD isn’t on the up and up with Macs. How can they release software/firmware that doesn’t even work on OS X? Makes you wonder if they even tested it…