My Book Duo - My Cloud offline and not the latest firmware

Hello,

I’m having trouble getting my My BookDuo to appear online in mycloud.com, The device is listed but I get a message saying it’s offline and I may need to accept the device security certificate.

Everything on the LAN works fine and the device settings show remote access enable and connected, port forwarding connection established. I’ve tried auto and manual with port forwarding rules set in the router and both show as connected from the device interface.

I have noticed a post saying firmware version 02.43.10 - 048 has been released that addresses the SSLv3 security vulnerability but when I check my device firmware it is running 02.42.02-012 and if a check for updates it says it is up to date.

The NAS is connected directly to my home router with no proxy.

I’m wondering if the issue offline is related to the firmware not updating as the browser will not accept an SSLv3 certificate?

Any help people can offer would be greatly appreciated.
Thanks

Looks Like I may have posted a bit prematurely, after a better look through the existing posts I found a download for the latest firmware and did a manual update. Problem solved.

Thanks to the people that take the time to extract and post the firmware file and make manual updates possible

You could try and download the firmware file and try perform a manual update? I also have a MyBookLive Duo and it has no problems operating with WD’s shiny OS3 and related utilities, but firmware is up-to-date,

The firmware download page is located here:

Thanks Myron, that’s exactly what and it worked like a charm.

1 Like

Awesome! Problem solved! :smile:
I like solved problems.

(Something you should know about software engineers. Not all the tweaks make it to a release notes document.)

I have the same problem. I have downloaded the .deb file and am going to try to manually update the firmware when I get home. The only problem is I have no idea how to manually update the firmware. I have searched the forums and can’t find a walkthrough anywhere. Any pointers?

Also, FYI; I am on Windows 10. I have read elsewhere that the MBLD is not compatible. Is that correct?

Hi Glenver, WD say on all all the documents that I found that manual updates are not possible any more but if you go to the web interface of your wd via the IP address and login you can go to settings -> system -> updates the option to update from file should be there. Just be patience when waiting for the update to finish and automatically reboot the device, It took a while for mine to complete and I almost pulled the power to reboot but glad I didn’t as it did finally finish and came back online.

Let us know how you get on.

Don’t pull the power during an update. There is also no harm is turning off the extra functions like iTunes and the media server before performing an update. It’s not needed, but turning off stuff during an update makes things simpler.

I was at work when I posted that last comment (not at the house) and didn’t realize there was a ‘update from file’ button. Once I got home I updated the firmware and I can now access my drive from the web (thank you!). So far now I have tried on my personal Windows 10 & Work Windows 7 machines but not my old personal Windows 8.1 machine (although I don’t foresee an issue).

I have not had enough time to map the drives so that will be my next step tonight. I realize this is probably not the appropriate place to bring this up but will I be able to map it on Windows 10? What about my wife’s Mac? Will I be able to have both of our machines utilize the drive or will that be an issue?

Thanks again!!!

1 Like

You should be able to use Mac and PC at the same time.

Hey Guys, I’m getting the Can’t Connect message when trying to use webbrowser to login remotely.

I’ve upgraded to firmware MyBookLiveDuo 02.43.10-048 : Core F/W from link in prev posts
I’ve disable and re-enbled the remote access button, connection status says Connected - Port forwarding connection established.
everytime I click on the accept your device security cert I just get page can’t be found
I’m able to connect via the My Cloud app on my android
works fine on the LAN

any ideas what I should try next?

Thanks
Mark