My Book Duo 16TB unlocker won't work - displays as generic CD

Hi all,

I recently got a 16TB my book duo. I already have an older 8TB model which I have encrypted, so I know how they work.

When I first booted up, the new duo was recognised as a new drive. I installed WD apps and set it to mirrored. All was good, I copied a folder to it & everything worked. Then I setup the password on it to test it. After a reboot, there was a CD drive. I am familiar with the old version, so I know that I open it & run the unlock program. But when I tried to double click the drive it says “Please insert a disc into CD drive”. This is not how it should work. The icon is the default windows CD drive, not the WD icon.

I have tried changing the drive letter but that didn’t work. The WD software doesn’t recognise the drive & says “please attach a drive”. I have tried removing usb devices from the device manager & the WD ses driver. I tried using different USB ports. None of those things work. Please help.

In disk management, the large disk (~8TB as it’s mirrored) is there but unallocated (as it should be before it is unlocked). The “CD drive” (i.e. the WD unlocker) is there but appears as a CD rom.

You can try uninstalling and reinstalling the WD Security software on the computer. To download the latest version of WD Security, refer to the link given below.

After installing the Wd Security again, you can follow the below mentioned steps and check if this works out for you or not.

  1. Close WD Security
  2. Navigate to the Control Panel, Administrative Tools, Services
  3. Look in the list for a service with the name “WD Drive Manager”, double click the service
  4. If the Startup type is set to Disabled (which in my case it was), change it to read Automatic then click Start, then Service status should read “Started”. Click OK
  5. Close the Services and Administrative Tools window, then open WD Security and the application should find the drive.